You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ol...@apache.org on 2024/06/27 07:45:26 UTC
(httpcomponents-website) 01/01: Updated project website for HttpClient 5.4-beta1 release
This is an automated email from the ASF dual-hosted git repository.
olegk pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-website.git
commit 1d3035e5a66f76750dabfe2049c70b42178ab80c
Author: Oleg Kalnichevski <ol...@apache.org>
AuthorDate: Thu Jun 27 09:27:17 2024 +0200
Updated project website for HttpClient 5.4-beta1 release
---
.../httpcomponents-client-5.4.x/examples-async.md | 7 +++
.../httpcomponents-client-5.4.x/examples.md | 7 +++
src/site/markdown/news.md | 57 ++++++++++++----------
.../documentation.links | 3 +-
src/site/site.xml | 4 +-
src/site/xdoc/downloads.xml | 26 +++++-----
6 files changed, 62 insertions(+), 42 deletions(-)
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/examples-async.md b/src/site/markdown/httpcomponents-client-5.4.x/examples-async.md
index 92609c9..0f560da 100644
--- a/src/site/markdown/httpcomponents-client-5.4.x/examples-async.md
+++ b/src/site/markdown/httpcomponents-client-5.4.x/examples-async.md
@@ -75,4 +75,11 @@ This example demonstrates handling of HTTP/2 message exchanges pushed by the ser
preemptive authentication can be considered less secure than a response to an authentication challenge and therefore
discouraged.
+- [HTTP version negotiation](https://github.com/apache/httpcomponents-client/tree/master/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttpVersionPolicy.java)
+ This example demonstrates how to make HttpClient negotiate or force a particular version of HTTP protocol during
+ the TLS handshake. Please note that protocol version policy setting also applies to non-HTTPS connections.
+
+- [Virtual HTTPS / SNI](https://github.com/apache/httpcomponents-client/tree/master/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientSNI.java)
+
+ This example demonstrates how to use SNI to send requests to a virtual HTTPS endpoint using the async I/O.
\ No newline at end of file
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/examples.md b/src/site/markdown/httpcomponents-client-5.4.x/examples.md
index 109ce3c..31c550e 100644
--- a/src/site/markdown/httpcomponents-client-5.4.x/examples.md
+++ b/src/site/markdown/httpcomponents-client-5.4.x/examples.md
@@ -105,3 +105,10 @@ HttpClient Examples (Classic)
This example shows how to execute requests enclosing a multipart encoded entity.
+- [Connection endpoint details](https://github.com/apache/httpcomponents-client/tree/master/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientRemoteEndpointDetails.java)
+
+ This example demonstrates how to get details of the underlying connection endpoint.
+
+- [Virtual HTTPS / SNI](https://github.com/apache/httpcomponents-client/tree/master/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientSNI.java)
+
+ This example demonstrates how to use SNI to send requests to a virtual HTTPS endpoint using the classic I/O.
\ No newline at end of file
diff --git a/src/site/markdown/news.md b/src/site/markdown/news.md
index 912726a..0a003c3 100644
--- a/src/site/markdown/news.md
+++ b/src/site/markdown/news.md
@@ -20,6 +20,37 @@
HttpComponents Project News
===========================
+###### 27 June 2024 - HttpComponents Client 5.4-beta1 released
+
+This is the first BETA release in the 5.4 release series. It upgrades HttpCore to version
+5.3-beta1 and adds a few minor improvements and fixes.
+
+Notable changes and features included in the 5.4 series:
+
+* Improved conformance to RFC 9110 (HTTP Semantics), RFC 7616 (HTTP Digest Access
+ Authentication), RFC 2617 (’Basic’ HTTP Authentication Scheme).
+
+* UTF-8 encoding is used by default for text where appropriate.
+
+* Compatibility with Java Virtual Threads and Java 21 Runtime.
+
+* Redesign and rewrite of the HTTP caching protocol layer for better efficiency
+ and improved conformance to RFC 9111 (HTTP Caching).
+
+* Cache control and context APIs.
+
+* ETag APIs.
+
+* TLS SNI and endpoint identification improvements.
+
+* Support for RFC 2817 (Upgrading to TLS Within HTTP/1.1).
+
+* Auth cache no longer makes use of Java serialization.
+
+* Deprecation of ConnectionSocketFactory and LayeredConnectionSocketFactory.
+
+* HttpContext optimization and performance improvement.
+
###### 26 June 2024 - HttpComponents Core 5.3-beta1 released
This is the first BETA release in the 5.3 release series. It features a re-designed
@@ -50,32 +81,6 @@ improves TLS customization for the classic transport, SNI and endpoint identific
support, authentication data caching, and HTTP context performance. It also introduces
support for optional TLS upgrades for HTTP/1.1 connections.
-Notable changes and features included in the 5.4 series:
-
-* Improved conformance to RFC 9110 (HTTP Semantics), RFC 7616 (HTTP Digest Access
- Authentication), RFC 2617 (’Basic’ HTTP Authentication Scheme).
-
-* UTF-8 encoding to be used by default for text where appropriate.
-
-* Compatibility with Java Virtual Threads and Java 21 Runtime.
-
-* Redesign and rewrite of the HTTP caching protocol layer for better efficiency
- and improved conformance to RFC 9111 (HTTP Caching).
-
-* Cache control and context APIs.
-
-* ETag APIs.
-
-* TLS SNI and endpoint identification improvements.
-
-* Support for RFC 2817 (Upgrading to TLS Within HTTP/1.1).
-
-* Auth cache no longer makes use of Java serialization.
-
-* Deprecation of ConnectionSocketFactory and LayeredConnectionSocketFactory.
-
-* HttpContext optimization and performance improvement.
-
###### 14 February 2024 - HttpComponents Core 5.3-alpha2 released
This is the second and likely the last ALPHA release in the 5.3 release series.
diff --git a/src/site/resources/httpcomponents-client-5.4.x/documentation.links b/src/site/resources/httpcomponents-client-5.4.x/documentation.links
index 0ec256d..f329f17 100644
--- a/src/site/resources/httpcomponents-client-5.4.x/documentation.links
+++ b/src/site/resources/httpcomponents-client-5.4.x/documentation.links
@@ -3,4 +3,5 @@
5.4-alpha1 ../components/httpcomponents-client-5.4.x/5.4-alpha1
5.4-alpha2 ../components/httpcomponents-client-5.4.x/5.4-alpha2
-current ../components/httpcomponents-client-5.4.x/5.4-alpha2
+5.4-beta1 ../components/httpcomponents-client-5.4.x/5.4-beta1
+current ../components/httpcomponents-client-5.4.x/5.4-beta1
diff --git a/src/site/site.xml b/src/site/site.xml
index 8f20feb..2d962f9 100644
--- a/src/site/site.xml
+++ b/src/site/site.xml
@@ -72,7 +72,7 @@ under the License.
<item name="Get Involved" href="get-involved.html"/>
</menu>
<menu name="Components">
- <item name="HttpClient 5.4 ALPHA" collapse="true" href="httpcomponents-client-5.4.x/index.html">
+ <item name="HttpClient 5.4 BETA" collapse="true" href="httpcomponents-client-5.4.x/index.html">
<item name="Quick Start" href="httpcomponents-client-5.4.x/quickstart.html"/>
<item name="Migration Guide" collapse="true" href="httpcomponents-client-5.3.x/migration-guide/index.html">
<item name="Preparation" href="httpcomponents-client-5.3.x/migration-guide/preparation.html"/>
@@ -106,7 +106,7 @@ under the License.
<item name="Related" href="httpcomponents-client-5.3.x/related-projects.html"/>
<item name="Download" href="httpcomponents-client-5.3.x/download.html"/>
</item>
- <item name="HttpCore 5.3 ALPHA" collapse="true" href="httpcomponents-core-5.3.x/index.html">
+ <item name="HttpCore 5.3 BETA" collapse="true" href="httpcomponents-core-5.3.x/index.html">
<item name="Examples" href="httpcomponents-core-5.3.x/examples.html"/>
<item name="Related" href="httpcomponents-core-5.2.x/related-projects.html"/>
<item name="Download" href="httpcomponents-core-5.3.x/download.html"/>
diff --git a/src/site/xdoc/downloads.xml b/src/site/xdoc/downloads.xml
index b56da61..cb2a61b 100644
--- a/src/site/xdoc/downloads.xml
+++ b/src/site/xdoc/downloads.xml
@@ -136,34 +136,34 @@
</ul>
</subsection>
- <subsection name="HttpClient 5.4-alpha2">
+ <subsection name="HttpClient 5.4-beta1">
<a href="https://downloads.apache.org/httpcomponents/httpclient/KEYS">KEYS</a>
<a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-5.4.x.txt">Release Notes</a>
<br/>
<p>Binary</p>
<ul>
<li>
- <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4-alpha2-bin.tar.gz">5.4-alpha2.tar.gz</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-alpha2-bin.tar.gz.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-alpha2-bin.tar.gz.asc">pgp</a>]
+ <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.tar.gz">5.4-beta1.tar.gz</a>
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.tar.gz.sha512">sha512</a>]
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.tar.gz.asc">pgp</a>]
</li>
<li>
- <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4-alpha2-bin.zip">5.4-alpha2.zip</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-alpha2-bin.zip.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-alpha2-bin.zip.asc">pgp</a>]
+ <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.zip">5.4-beta1.zip</a>
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.zip.sha512">sha512</a>]
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.zip.asc">pgp</a>]
</li>
</ul>
<p>Source</p>
<ul>
<li>
- <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4-alpha2-src.tar.gz">5.4-alpha2.tar.gz</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-alpha2-src.tar.gz.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-alpha2-src.tar.gz.asc">pgp</a>]
+ <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.tar.gz">5.4-beta1.tar.gz</a>
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.tar.gz.sha512">sha512</a>]
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.tar.gz.asc">pgp</a>]
</li>
<li>
- <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4-alpha2-src.zip">5.4-alpha2.zip</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-alpha2-src.zip.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-alpha2-src.zip.asc">pgp</a>]
+ <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.zip">5.4-beta1.zip</a>
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.zip.sha512">sha512</a>]
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.zip.asc">pgp</a>]
</li>
</ul>
</subsection>