You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Benjamin Hindman <be...@berkeley.edu> on 2017/01/14 22:32:35 UTC

Review Request 55541: Replaced (another) recursive implementation with process::loop.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55541/
-----------------------------------------------------------

Review request for mesos, Alexander Rukletsov, Anand Mazumdar, Benjamin Mahler, and Kevin Klues.


Bugs: MESOS-6913
    https://issues.apache.org/jira/browse/MESOS-6913


Repository: mesos


Description
-------

Replaced (another) recursive implementation with process::loop.


Diffs
-----

  3rdparty/libprocess/src/http.cpp 8895f0cfadf1cca9714fc7110ed0914e3db18983 

Diff: https://reviews.apache.org/r/55541/diff/


Testing
-------

make check


Thanks,

Benjamin Hindman


Re: Review Request 55541: Replaced (another) recursive implementation with process::loop.

Posted by Benjamin Hindman <be...@berkeley.edu>.

> On Jan. 16, 2017, 9:10 a.m., Alexander Rukletsov wrote:
> > 3rdparty/libprocess/src/http.cpp, lines 1003-1004
> > <https://reviews.apache.org/r/55541/diff/1/?file=1605531#file1605531line1003>
> >
> >     I see that you simply restore the previous behaviour here, but still, I don't see how we can enter the `.onDiscarded()` branch.

There's nothing to say that reading from the reader might not get discarded so the defensive thing here is to keep the previous behavior.


- Benjamin


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55541/#review161696
-----------------------------------------------------------


On Jan. 14, 2017, 10:32 p.m., Benjamin Hindman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/55541/
> -----------------------------------------------------------
> 
> (Updated Jan. 14, 2017, 10:32 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov, Anand Mazumdar, Benjamin Mahler, and Kevin Klues.
> 
> 
> Bugs: MESOS-6913
>     https://issues.apache.org/jira/browse/MESOS-6913
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Replaced (another) recursive implementation with process::loop.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/src/http.cpp 8895f0cfadf1cca9714fc7110ed0914e3db18983 
> 
> Diff: https://reviews.apache.org/r/55541/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Hindman
> 
>


Re: Review Request 55541: Replaced (another) recursive implementation with process::loop.

Posted by Alexander Rukletsov <ru...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55541/#review161696
-----------------------------------------------------------


Fix it, then Ship it!





3rdparty/libprocess/src/http.cpp (line 967)
<https://reviews.apache.org/r/55541/#comment233008>

    Please rename `reader` to something else to avoid shadowing `reader` defined at L953. `requestReader`?



3rdparty/libprocess/src/http.cpp (lines 989 - 990)
<https://reviews.apache.org/r/55541/#comment233009>

    I see that you simply restore the previous behaviour here, but still, I don't see how we can enter the `.onDiscarded()` branch.


- Alexander Rukletsov


On Jan. 14, 2017, 10:32 p.m., Benjamin Hindman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/55541/
> -----------------------------------------------------------
> 
> (Updated Jan. 14, 2017, 10:32 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov, Anand Mazumdar, Benjamin Mahler, and Kevin Klues.
> 
> 
> Bugs: MESOS-6913
>     https://issues.apache.org/jira/browse/MESOS-6913
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Replaced (another) recursive implementation with process::loop.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/src/http.cpp 8895f0cfadf1cca9714fc7110ed0914e3db18983 
> 
> Diff: https://reviews.apache.org/r/55541/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Hindman
> 
>