You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@servicemix.apache.org by "Jean-Baptiste Onofré (JIRA)" <ji...@apache.org> on 2010/02/24 15:06:40 UTC

[jira] Created: (SMX4-491) Wrap commons-pool 1.4 and 1.5.4 in servicemix bundles

Wrap commons-pool 1.4 and 1.5.4 in servicemix bundles
-----------------------------------------------------

                 Key: SMX4-491
                 URL: https://issues.apache.org/activemq/browse/SMX4-491
             Project: ServiceMix 4
          Issue Type: Bug
            Reporter: Jean-Baptiste Onofré
            Assignee: Jean-Baptiste Onofré


Camel 2.2.0 needs commons-pool 1.5.4.
ActiveMQ pool needs commons-pool 1.4.
So in ServiceMix 4, we deploy both commons-pool 1.5.4 and 1.4 bundles.

Unfortunately, commons-pool 1.4 is not a "correct" bundle as it contains:
Export-Package = org.apache.commons.pool;version=1.4, org.apache.commons.pool.impl;version=1.4
Import-Package = org.apache.commons.pool;version=1.4, org.apache.commons.pool.impl;version=1.4

So what happens in this case is that commons-pool 1.4 will not export its package but import the 1.5.4 one.

The problem is exactly the same with commons-pool 1.5.4.

The workaround is to create a new ServiceMix commons-pool package which wrap commons-pool and define correct Export-Package and Import-Package statements.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (SMX4-491) Wrap commons-pool 1.4 and 1.5.4 in servicemix bundles

Posted by "Jean-Baptiste Onofré (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/SMX4-491?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=57841#action_57841 ] 

Jean-Baptiste Onofré commented on SMX4-491:
-------------------------------------------

The ServiceMix commons-pool bundles are now available.
I'm going to use it in ServiceMix features/assembly.

> Wrap commons-pool 1.4 and 1.5.4 in servicemix bundles
> -----------------------------------------------------
>
>                 Key: SMX4-491
>                 URL: https://issues.apache.org/activemq/browse/SMX4-491
>             Project: ServiceMix 4
>          Issue Type: Bug
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>
> Camel 2.2.0 needs commons-pool 1.5.4.
> ActiveMQ pool needs commons-pool 1.4.
> So in ServiceMix 4, we deploy both commons-pool 1.5.4 and 1.4 bundles.
> Unfortunately, commons-pool 1.4 is not a "correct" bundle as it contains:
> Export-Package = org.apache.commons.pool;version=1.4, org.apache.commons.pool.impl;version=1.4
> Import-Package = org.apache.commons.pool;version=1.4, org.apache.commons.pool.impl;version=1.4
> So what happens in this case is that commons-pool 1.4 will not export its package but import the 1.5.4 one.
> The problem is exactly the same with commons-pool 1.5.4.
> The workaround is to create a new ServiceMix commons-pool package which wrap commons-pool and define correct Export-Package and Import-Package statements.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (SMX4-491) Wrap commons-pool 1.4 and 1.5.4 in servicemix bundles

Posted by "Jean-Baptiste Onofré (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/SMX4-491?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=57862#action_57862 ] 

Jean-Baptiste Onofré commented on SMX4-491:
-------------------------------------------

I submitted a patch to commons-pool:
https://issues.apache.org/jira/browse/POOL-160

> Wrap commons-pool 1.4 and 1.5.4 in servicemix bundles
> -----------------------------------------------------
>
>                 Key: SMX4-491
>                 URL: https://issues.apache.org/activemq/browse/SMX4-491
>             Project: ServiceMix 4
>          Issue Type: Bug
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>
> Camel 2.2.0 needs commons-pool 1.5.4.
> ActiveMQ pool needs commons-pool 1.4.
> So in ServiceMix 4, we deploy both commons-pool 1.5.4 and 1.4 bundles.
> Unfortunately, commons-pool 1.4 is not a "correct" bundle as it contains:
> Export-Package = org.apache.commons.pool;version=1.4, org.apache.commons.pool.impl;version=1.4
> Import-Package = org.apache.commons.pool;version=1.4, org.apache.commons.pool.impl;version=1.4
> So what happens in this case is that commons-pool 1.4 will not export its package but import the 1.5.4 one.
> The problem is exactly the same with commons-pool 1.5.4.
> The workaround is to create a new ServiceMix commons-pool package which wrap commons-pool and define correct Export-Package and Import-Package statements.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (SMX4-491) Wrap commons-pool 1.4 and 1.5.4 in servicemix bundles

Posted by "Jean-Baptiste Onofré (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/activemq/browse/SMX4-491?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jean-Baptiste Onofré resolved SMX4-491.
---------------------------------------

       Resolution: Fixed
    Fix Version/s: 4.2.0

ServiceMix 4.1.0-SNAPSHOT assembly is now correct: no more issue with activemq-pool and commons-pool.

> Wrap commons-pool 1.4 and 1.5.4 in servicemix bundles
> -----------------------------------------------------
>
>                 Key: SMX4-491
>                 URL: https://issues.apache.org/activemq/browse/SMX4-491
>             Project: ServiceMix 4
>          Issue Type: Bug
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.2.0
>
>
> Camel 2.2.0 needs commons-pool 1.5.4.
> ActiveMQ pool needs commons-pool 1.4.
> So in ServiceMix 4, we deploy both commons-pool 1.5.4 and 1.4 bundles.
> Unfortunately, commons-pool 1.4 is not a "correct" bundle as it contains:
> Export-Package = org.apache.commons.pool;version=1.4, org.apache.commons.pool.impl;version=1.4
> Import-Package = org.apache.commons.pool;version=1.4, org.apache.commons.pool.impl;version=1.4
> So what happens in this case is that commons-pool 1.4 will not export its package but import the 1.5.4 one.
> The problem is exactly the same with commons-pool 1.5.4.
> The workaround is to create a new ServiceMix commons-pool package which wrap commons-pool and define correct Export-Package and Import-Package statements.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.