You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Yunchi Pang (Jira)" <ji...@apache.org> on 2025/07/02 02:14:00 UTC

[jira] (HDDS-13247) [Snapshot] Duplicate code snippets in OMSnapshotMoveDeletedKeysRequest and OMSnapshotMoveTableKeysRequest

    [ https://issues.apache.org/jira/browse/HDDS-13247 ]


    Yunchi Pang deleted comment on HDDS-13247:
    ------------------------------------

was (Author: JIRAUSER309280):
can i pick this up? thanks!

> [Snapshot] Duplicate code snippets in OMSnapshotMoveDeletedKeysRequest and OMSnapshotMoveTableKeysRequest
> ---------------------------------------------------------------------------------------------------------
>
>                 Key: HDDS-13247
>                 URL: https://issues.apache.org/jira/browse/HDDS-13247
>             Project: Apache Ozone
>          Issue Type: Sub-task
>            Reporter: Wei-Chiu Chuang
>            Priority: Trivial
>
> OMSnapshotMoveTableKeysRequest.validateAndUpdateCache() and OMSnapshotMoveDeletedKeysRequest.validateAndUpdateCache() have duplicate code snippets.
> Let's consolidate them into one single helper method?



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org