You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@isis.apache.org by "Dan Haywood (JIRA)" <ji...@apache.org> on 2016/11/30 18:49:58 UTC

[jira] [Updated] (ISIS-1548) Allow @Mixin annotation to specify the verb to use for the action (instead of '$$'); allow '$' to be used as separator.

     [ https://issues.apache.org/jira/browse/ISIS-1548?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dan Haywood updated ISIS-1548:
------------------------------
    Description: 
The current mixin conventions gives rise to code such as:

{code}
mixin(Invoice._approve.class, invoice).$$();
{code}

where:

{code}
public class Invoice {
    ...
    @Mixin
    public static class _approve {
        ...
        public Invoice $$() { ... }
    }
}
{code}

We'd like it instead to read:    

{code}
mixin(Invoice.Approve.class, invoice).exec();
{code}

ie:

* change "$$" to "exec" (or any other verb)
* not require the leading "_" in the mixin name
* allow the class to be capitalized

Suggestion is:

{code}
public class Invoice {
    ...
    @Mixin("exec")
    public static class Approve {
        public void exec() { ... }
    }
}
{code}


  was:
The current mixin conventions gives rise to code such as:

{code}
mixin(Invoice._invoice.class, invoice).$$(invoiceDate);
{code}

where:

{code}
public class Invoice {
    ...
    @Mixin
    public static class _invoice {
        ...
        public Invoice $$(LocalDate invoiceDate) { ... }
    }
}
{code}

We'd like it instead to read:    

{code}
mixin(Invoice.invoice.class, invoice).exec(invoiceDate);
{code}

ie, change "$$" to "exec and not require the leading "_" in the mixin name

Suggestion is:

{code}
public class Invoice {
    ...
    @Mixin("exec")
    public class invoice {
        public void exec(LocalDate invoiceDate) { ... }
    }
}
{code}



> Allow @Mixin annotation to specify the verb to use for the action (instead of '$$'); allow '$' to be used as separator.
> -----------------------------------------------------------------------------------------------------------------------
>
>                 Key: ISIS-1548
>                 URL: https://issues.apache.org/jira/browse/ISIS-1548
>             Project: Isis
>          Issue Type: Improvement
>    Affects Versions: 1.13.1
>            Reporter: Dan Haywood
>            Priority: Minor
>             Fix For: 1.13.2
>
>
> The current mixin conventions gives rise to code such as:
> {code}
> mixin(Invoice._approve.class, invoice).$$();
> {code}
> where:
> {code}
> public class Invoice {
>     ...
>     @Mixin
>     public static class _approve {
>         ...
>         public Invoice $$() { ... }
>     }
> }
> {code}
> We'd like it instead to read:    
> {code}
> mixin(Invoice.Approve.class, invoice).exec();
> {code}
> ie:
> * change "$$" to "exec" (or any other verb)
> * not require the leading "_" in the mixin name
> * allow the class to be capitalized
> Suggestion is:
> {code}
> public class Invoice {
>     ...
>     @Mixin("exec")
>     public static class Approve {
>         public void exec() { ... }
>     }
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)