You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Philippe Cloutier (Jira)" <ji...@apache.org> on 2023/12/05 17:48:00 UTC

[jira] [Commented] (BEANUTILS-210) copyProperties should have optional flag for including transient member variables

    [ https://issues.apache.org/jira/browse/BEANUTILS-210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17793374#comment-17793374 ] 

Philippe Cloutier commented on BEANUTILS-210:
---------------------------------------------

{{I don't think such a method should be named copyNotTransients. It would be more discoverable to have an optional flag indeed.}}

{{Flags could also allow filtering properties based on their annotations.}}

> copyProperties should have optional flag for including transient member variables
> ---------------------------------------------------------------------------------
>
>                 Key: BEANUTILS-210
>                 URL: https://issues.apache.org/jira/browse/BEANUTILS-210
>             Project: Commons BeanUtils
>          Issue Type: Improvement
>          Components: Bean / Property Utils
>         Environment: Operating System: other
> Platform: Other
>            Reporter: Nathan Egge
>            Priority: Minor
>             Fix For: 2.0.0
>
>
> The EqualsBuilder, HashCodeBuilder, and ToStringBuilder all have a flag for
> allowing you to use only the non-transient member variables on an object.  The
> BeanUtils.copyProperties method should have a similar such variable (which can
> default to false) so you can designate only some variables to copy across domains.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)