You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@cloudstack.apache.org by "Bharat Kumar (JIRA)" <ji...@apache.org> on 2014/01/08 14:05:50 UTC
[jira] [Commented] (CLOUDSTACK-5651) deployVm: customparameters
param name has to be changed
[ https://issues.apache.org/jira/browse/CLOUDSTACK-5651?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13865392#comment-13865392 ]
Bharat Kumar commented on CLOUDSTACK-5651:
------------------------------------------
Hi,
The customParameter name is used to indicate that it should be passed when using customised values for some parameters of a
vm. This is not metadata. as of now we use this to pass custom values of cpu, memory and cup cores.
However to be consistent with the other APIs we are changing this name to details. which is vague as detail which can be anything that is related to a vm. Also we populate these details in the response.
> deployVm: customparameters param name has to be changed
> -------------------------------------------------------
>
> Key: CLOUDSTACK-5651
> URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5651
> Project: CloudStack
> Issue Type: Bug
> Security Level: Public(Anyone can view this level - this is the default.)
> Affects Versions: 4.3.0
> Reporter: Alena Prokharchyk
> Assignee: Bharat Kumar
> Priority: Critical
> Fix For: 4.3.0
>
>
> deployVm API got a new param in 4.3 -“customparameters”. The description of the parameter is very vague and generic “used to specify the custom parameters”.
> Is it just the metadata in form of value/key pairs? If so, please change the name to “details” - the generic name used when specify key/value metadata in other API commands.
> Also you need to save this information in the “user_vm_details” table, and return it in the UserVmResponse, “details” map parameter. I don’t see “custom parameters” key map being returned anywhere in the UserVmResponse. Its very confusing, because whatever is passed to the Create/Update call, should be returned in the response as well.
> It all has to be fixed in 4.3 branch.
--
This message was sent by Atlassian JIRA
(v6.1.5#6160)