You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@trafficserver.apache.org by "James Peach (JIRA)" <ji...@apache.org> on 2014/03/25 01:07:46 UTC

[jira] [Updated] (TS-2660) rename state machine action values

     [ https://issues.apache.org/jira/browse/TS-2660?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

James Peach updated TS-2660:
----------------------------

    Labels: Review  (was: )

> rename state machine action values
> ----------------------------------
>
>                 Key: TS-2660
>                 URL: https://issues.apache.org/jira/browse/TS-2660
>             Project: Traffic Server
>          Issue Type: Bug
>          Components: Cleanup
>            Reporter: James Peach
>              Labels: Review
>
> The values of {{StateMachineAction_t}} do not adhere to any naming convention, making them hard to recognize and find in code. We should apply a naming convention and remove unused values.
> The patch I have ends up with this set of values:
> {code}
>     SM_ACTION_UNDEFINED = 0,
>     // SM_ACTION_AUTH_LOOKUP,
>     SM_ACTION_DNS_LOOKUP,
>     SM_ACTION_DNS_REVERSE_LOOKUP,
>     SM_ACTION_CACHE_LOOKUP,
>     SM_ACTION_CACHE_ISSUE_WRITE,
>     SM_ACTION_CACHE_ISSUE_WRITE_TRANSFORM,
>     SM_ACTION_CACHE_PREPARE_UPDATE,
>     SM_ACTION_CACHE_ISSUE_UPDATE,
>     SM_ACTION_ICP_QUERY,
>     SM_ACTION_ORIGIN_SERVER_OPEN,
>     SM_ACTION_ORIGIN_SERVER_RAW_OPEN,
>     SM_ACTION_ORIGIN_SERVER_RR_MARK_DOWN,
>     SM_ACTION_READ_PUSH_HDR,
>     SM_ACTION_STORE_PUSH_BODY,
>     SM_ACTION_INTERNAL_CACHE_DELETE,
>     SM_ACTION_INTERNAL_CACHE_NOOP,
>     SM_ACTION_INTERNAL_CACHE_UPDATE_HEADERS,
>     SM_ACTION_INTERNAL_CACHE_WRITE,
>     SM_ACTION_INTERNAL_100_RESPONSE,
>     SM_ACTION_INTERNAL_REQUEST,
>     SM_ACTION_SEND_ERROR_CACHE_NOOP,
> #ifdef PROXY_DRAIN
>     SM_ACTION_DRAIN_REQUEST_BODY,
> #endif /* PROXY_DRAIN */
>     SM_ACTION_SERVE_FROM_CACHE,
>     SM_ACTION_SERVER_READ,
>     SM_ACTION_SERVER_PARSE_NEXT_HDR,
>     SM_ACTION_TRANSFORM_READ,
>     SM_ACTION_SSL_TUNNEL,
>     SM_ACTION_CONTINUE,
>     SM_ACTION_API_SM_START,
>     SM_ACTION_API_READ_REQUEST_HDR,
>     SM_ACTION_API_PRE_REMAP,
>     SM_ACTION_API_POST_REMAP,
>     SM_ACTION_API_OS_DNS,
>     SM_ACTION_API_SEND_REQUEST_HDR,
>     SM_ACTION_API_READ_CACHE_HDR,
>     SM_ACTION_API_CACHE_LOOKUP_COMPLETE,
>     SM_ACTION_API_READ_RESPONSE_HDR,
>     SM_ACTION_API_SEND_RESPONSE_HDR,
>     SM_ACTION_API_SM_SHUTDOWN,
>     SM_ACTION_REMAP_REQUEST,
>     SM_ACTION_POST_REMAP_SKIP,
>     SM_ACTION_REDIRECT_READ
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)