You are viewing a plain text version of this content. The canonical link for it is here.
Posted to user@superset.apache.org by Daniel Gaspar <dp...@apache.org> on 2023/12/19 09:44:03 UTC
CVE-2023-49734: Apache Superset: Privilege Escalation Vulnerability
Affected versions:
- Apache Superset before 2.1.2
- Apache Superset 3.0.0 before 3.0.2
Description:
An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2.
Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.
Credit:
Jordan Velich (finder)
References:
https://superset.apache.org
https://www.cve.org/CVERecord?id=CVE-2023-49734