You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@spamassassin.apache.org by Adam Katz <an...@khopis.com> on 2010/05/29 01:32:27 UTC
Re: [SA-dev] perl 5.12 fixes released to CPAN?
On 05/05/2010 02:33 PM, Sidney Markowitz wrote:
> I haven't followed the perl 5.12 patches, but it makes sense to me
> that 5.12 compatibility would be a good thing to fold in. Other
> devs, please speak up +1 or -1 on that.
-1
5.12 compatibility is fine. A 5.12 /dependency/ is bad, though
perhaps acceptable for a 3.4.0 dependency assuming 5.12 has found its
way into the enterprise OS's with enough buffer before SA 3.4's release.
Perl 5.12 is only one month old and has only been packaged by ONE
distribution to date.
hasn't yet hit even Debian Unstable (which is still on 5.10.1). Both
Debian Stable (Lenny is stuck at 5.10) and Red Hat Enterprise (RHEL5
is stuck at 5.8) work fine in 3.3.1 but would have enormous hoops to
jump through to upgrade to 5.12. The RHEL6 beta features perl 5.10.1,
which probably means that the final release, expected at the end of
the year(?), will ship 5.10.x. Solaris 10 has 5.8.4, as does
OpenSolaris 2009.06 (which has a five year commercial support
commitment from Oracle, who dubs it a kind of preview for Solaris 11).
Here's where things stand. Asterisked items are not yet released.
Data from www.distrowatch.com
Debian 5.0 (Lenny) 5.10.0
*Debian 6.0 (Squeeze) 5.10.1
*Debian Unstable (Sid) 5.10.1
Ubuntu 10.04 LTS 5.10.1
*Ubuntu 10.10 snap 5.10.1
Novell/SUSE Ent 11 5.10.0
openSUSE 11.2 5.10.0
*openSUSE factory 5.12.0
Red Hat Ent 5.5 5.8.8 (and thus CentOS et al)
*Red Hat Ent 6 Beta 5.10.1
Fedora 13 5.10.1
*Fedora Rawhide 5.10.1
Mandriva 2010 5.10.1
*Mandriva cooker 5.10.1
Gentoo 10.1 5.8.8
Gentoo stable 5.8.8
*Gentoo unstable 5.10.1
Sun Solaris 10 5.8.4
OpenSolaris 2009.06 5.8.4 (5y support, ~preview of Solaris 11)
OpenBSD 4.7 5.10.1
FreeBSD 8 Stable 5.8.9
*FreeBSD 8 Release 5.10.1
*FreeBSD 9 Current 5.8.9 (huh?)
NetBSD 5.0 5.10.0
*NetBSD pkgsrc 5.10.1
DragonFly BSD 2.4 5.10.0
Re: perl 5.12 fixes released to CPAN?
Posted by Karsten Bräckelmann <gu...@rudersport.de>.
On Fri, 2010-05-28 at 19:32 -0400, Adam Katz wrote:
> > I haven't followed the perl 5.12 patches, but it makes sense to me
> > that 5.12 compatibility would be a good thing to fold in. Other
> > devs, please speak up +1 or -1 on that.
>
> -1
>
> 5.12 compatibility is fine. A 5.12 /dependency/ is bad, though
> perhaps acceptable for a 3.4.0 dependency assuming 5.12 has found its
> way into the enterprise OS's with enough buffer before SA 3.4's release.
>
> Perl 5.12 is only one month old and has only been packaged by ONE
> distribution to date.
Huh?
I appear not to have kept the previous discussion, but this is obviously
about *compatibility* with 5.12 -- that means, not to break when run
with Perl 5.12. No one ever suggested raising the dependency bar.
In fact, SA 3.3 just dropped official support for Perl 5.6, which means
it still might run under 5.6, and we would even be willing to get fixes
in. However, we do not promise support for 5.6, and it might break with
that version at any time.
Dropping the old 5.6 from the officially supported set of Perl versions
was a hard discussion already. How did you get the impression we would
drop support for 5.8 and 5.10 *that* easily? Let alone in a micro
version bump...
Compatibility fixes are a good thing. Whether Perl 5.12, or obsolete
versions hardly run today like 5.6. The latter strongly preferred with
community provided patches. ;)
--
char *t="\10pse\0r\0dtu\0.@ghno\x4e\xc8\x79\xf4\xab\x51\x8a\x10\xf4\xf4\xc4";
main(){ char h,m=h=*t++,*x=t+2*h,c,i,l=*x,s=0; for (i=0;i<l;i++){ i%8? c<<=1:
(c=*++x); c&128 && (s+=h); if (!(h>>=1)||!t[s+h]){ putchar(t[s]);h=m;s=0; }}}
Re: perl 5.12 fixes released to CPAN?
Posted by Mark Martinec <Ma...@ijs.si>.
As far as I know there were no changes committed to any branch
that would break compatibility with 5.6-5.10 in favour of 5.12.
The only patch in this context was to avoid a construct
(a goto into a structure) which makes 5.12 complain, but goes
unnoticed by earlier versions of perl.
Mark
Re: perl 5.12 fixes released to CPAN?
Posted by Adam Katz <an...@khopis.com>.
On 05/28/2010 08:51 PM, Sidney Markowitz wrote:
> Adam, do you want to rescind the -1 vote based on the above, or did
> you notice something about the patches that may break compatibility
> with earlier versions of perl? I have not actually looked at the
> patches yet, so I am not offering an opinion one way or the other,
> just calling for votes from people who have looked at it.
Rescinded. Sorry for the confusion.
I knew there was something I wanted to more thoroughly look over
before sending that (the perils of trying to wedge this in without
conflicting with work!) ... it had been sitting half-composed for a
while and I just sent it rather than finishing it. Apologies again.
Re: perl 5.12 fixes released to CPAN?
Posted by Sidney Markowitz <si...@sidney.com>.
Adam Katz wrote, On 29/05/10 11:32 AM:
> On 05/05/2010 02:33 PM, Sidney Markowitz wrote:
>> I haven't followed the perl 5.12 patches, but it makes sense to me
>> that 5.12 compatibility would be a good thing to fold in. Other
>> devs, please speak up +1 or -1 on that.
>
> -1
>
> 5.12 compatibility is fine. A 5.12 /dependency/ is bad
I'm essentially repeating what Karsten said, but to make sure this is
clear: My understanding of this thread is that the 5.12 compatibility
patches, which fix errors that appear when running under 5.12 but do not
break running under earlier versions of perl, have already been
committed to trunk. What I asked about is votes for folding the patches
into the 3.3 branch before we release 3.3.2 so that it will be released
with compatibility for 5.6 through 5.12 instead of 5.6 through 5.10.
(The 5.6 compatibility being not officially supported but not yet broken).
The kind of reasons I'm expecting for a +1 vote would be because
compatibility with 5.12 is a good thing to get in early even if 5.12 is
not popular yet and because the patches are not risky in terms of
possibly introducing new bugs or incompatibilities with perl 5.6 - 5.10.
The kinds of reasons I would expect if someone were to vote -1 would be
that the specific patches do break compatibility with earlier versions
of perl, or have not been tested well enough with the older versions, or
are too extensive to risk in a point release or won't apply to the 3.3
branch code without extensive rewriting.
Adam, do you want to rescind the -1 vote based on the above, or did you
notice something about the patches that may break compatibility with
earlier versions of perl? I have not actually looked at the patches yet,
so I am not offering an opinion one way or the other, just calling for
votes from people who have looked at it.
-- Sidney