You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@geronimo.apache.org by "David Jencks (JIRA)" <de...@geronimo.apache.org> on 2005/01/10 20:07:13 UTC

[jira] Commented: (GERONIMO-450) GBeans should use jsr-77 naming conventions and these names should have mostly default components

     [ http://issues.apache.org/jira/browse/GERONIMO-450?page=comments#action_57482 ]
     
David Jencks commented on GERONIMO-450:
---------------------------------------

I've implemented some parts of this.  gbean xml config can specify namePart and type for name and j2eeType portions of the generated ObjectName, or can specify the entire object name as name.  Extracting the domain and server from the top-level plan is not yet implemented.

An additional desirable feature would be replacing literal object names in references by the parts that differ from the context.  This would involve either two elements for reference patterns or a backward incompatible change to avoid mixed context.

> GBeans should use jsr-77 naming conventions and these names should have mostly default components
> -------------------------------------------------------------------------------------------------
>
>          Key: GERONIMO-450
>          URL: http://issues.apache.org/jira/browse/GERONIMO-450
>      Project: Apache Geronimo
>         Type: Improvement
>   Components: deployment
>     Versions: 1.0-M2
>     Reporter: David Jencks
>     Assignee: David Jencks

>
> Currently the usage of object names for non-j2ee-wrapping gbeans is more or less random and confusing.  We should adopt as much of jsr-77 naming as possible for our gbeans.  Furthermore, as little as possible of the names should be specified in the gbean xml descriptor.  Here's a proposal:
> 1. A service module that has no parent must specify domain and server name.  This domain and server name will be inherited by all children recursively.
> 2. All gbeans deployed from a service dd will have J2EEApplication=null and GeronimoModule=<configId>
> 3. All gbeans deployed from a j2ee module or application will have J2EEApplication set from the application and GeronimoModule=<configId>
> 4. A gbean xml descriptor will have attributes for j2eeType and name.  We will invent more j2eeType names as needed and prefix them with Ger or Geronimo.
> I'm inclined to remove the possibility of directly specifying the entire object name.  If it is really needed I'd suggest the attribute be called target-name in analogy to the usage in refs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira