You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Garrett Rooney <ro...@electricjellyfish.net> on 2001/09/18 00:05:30 UTC

[PATCH] svn_fs_contents_changed

while reading over the subversion source code this weekend, i noticed
that svn_fs_contents_changed() was taking a pointer to an int as one
of its arguments, when it was using it as a bool.  this patch changes
it to use an svn_boolean_t for clarity and updates the only place in
the tree that calls it.  maybe it'll save someone else from a moment
of confusion later on.

* svn_fs.h (svn_fs_contents_changed): change changed_p to a
  svn_boolean_t instead of an int for clarity.
* tree.c (svn_fs_contents_changed): change changed_p to a
  svn_boolean_t instead of an int for clarity.
* path.c (delta_files): change changed to a svn_boolean_t for clarity.

-- 
garrett rooney                     Unix was not designed to stop you from 
rooneg@electricjellyfish.net       doing stupid things, because that would  
http://electricjellyfish.net/      stop you from doing clever things.

Re: [PATCH] svn_fs_contents_changed

Posted by Garrett Rooney <ro...@electricjellyfish.net>.
On Mon, Sep 17, 2001 at 11:44:44PM -0500, cmpilato@collab.net wrote:
> Garrett Rooney <ro...@electricjellyfish.net> writes:
> 
> > while reading over the subversion source code this weekend, i noticed
> > that svn_fs_contents_changed() was taking a pointer to an int as one
> > of its arguments, when it was using it as a bool.  this patch changes
> > it to use an svn_boolean_t for clarity and updates the only place in
> > the tree that calls it.  maybe it'll save someone else from a moment
> > of confusion later on.
> 
> Sorry, I have to -1 this one (on Jim's behalf).  We've been here
> before, and the FS interface conistently ignores the existence of
> svn_boolean_t and svn_string*, by design.  If everyone wants to change
> it, I certainly won't care, but I know this has been visited before
> with respect the libsvn_fs.

ok, no big deal.

-- 
garrett rooney                     Unix was not designed to stop you from 
rooneg@electricjellyfish.net       doing stupid things, because that would  
http://electricjellyfish.net/      stop you from doing clever things.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: [PATCH] svn_fs_contents_changed

Posted by cm...@collab.net.
Garrett Rooney <ro...@electricjellyfish.net> writes:

> while reading over the subversion source code this weekend, i noticed
> that svn_fs_contents_changed() was taking a pointer to an int as one
> of its arguments, when it was using it as a bool.  this patch changes
> it to use an svn_boolean_t for clarity and updates the only place in
> the tree that calls it.  maybe it'll save someone else from a moment
> of confusion later on.

Sorry, I have to -1 this one (on Jim's behalf).  We've been here
before, and the FS interface conistently ignores the existence of
svn_boolean_t and svn_string*, by design.  If everyone wants to change
it, I certainly won't care, but I know this has been visited before
with respect the libsvn_fs.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org