You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Dian Fu (Jira)" <ji...@apache.org> on 2025/05/22 02:58:00 UTC

[jira] [Closed] (FLINK-37823) Add Python 3.12 support

     [ https://issues.apache.org/jira/browse/FLINK-37823?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dian Fu closed FLINK-37823.
---------------------------
    Resolution: Fixed

Merged to master via 5eeb2fc8197073c97713390a224b383b47f56c91.

> Add Python 3.12 support
> -----------------------
>
>                 Key: FLINK-37823
>                 URL: https://issues.apache.org/jira/browse/FLINK-37823
>             Project: Flink
>          Issue Type: Technical Debt
>          Components: API / Python
>            Reporter: Mika Naylor
>            Assignee: Mika Naylor
>            Priority: Major
>              Labels: pull-request-available
>
> We currently can’t install apache-flink on Python 3.12 due to a pemja dependency blocker:
> {code:java}
> λ uv pip install apache-flink
> Using Python 3.12.10 environment at: .3122
> Resolved 53 packages in 3.50s
>   × Failed to download and build `pemja==0.4.1`
>   ╰─▶ Build backend failed to determine requirements with `build_wheel()` (exit status: 1)      [stderr]
>       Traceback (most recent call last):
>         File "<string>", line 8, in <module>
>         File "python3.12/site-packages/setuptools/__init__.py", line 10, in <module>
>           import distutils.core
>       ModuleNotFoundError: No module named 'distutils'      hint: `distutils` was removed from the standard library in Python 3.12. Consider adding a constraint (like `pemja >0.4.1`) to avoid building a version of `pemja` that depends on `distutils`.
>   help: `pemja` (v0.4.1) was included because `apache-flink` (v2.0.0) depends on `pemja`
> {code}
> As of 5.0, Pemja supports 3.12 [https://pypi.org/project/pemja/0.5.0/]



--
This message was sent by Atlassian Jira
(v8.20.10#820010)