You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Chesnay Schepler (JIRA)" <ji...@apache.org> on 2018/02/16 20:58:00 UTC

[jira] [Created] (FLINK-8684) Rework MesosTaskManagerParameters#MESOS_RM_TASKS_SLOTS

Chesnay Schepler created FLINK-8684:
---------------------------------------

             Summary: Rework MesosTaskManagerParameters#MESOS_RM_TASKS_SLOTS
                 Key: FLINK-8684
                 URL: https://issues.apache.org/jira/browse/FLINK-8684
             Project: Flink
          Issue Type: Improvement
          Components: Documentation, Mesos
    Affects Versions: 1.5.0
            Reporter: Chesnay Schepler
             Fix For: 1.5.0


Currently, {{MesosTaskManagerParameters#MESOS_RM_TASKS_SLOTS}} mimics {{TaskManagerOptions#NUM_TASK_SLOTS}}:
{code:java}
public static final ConfigOption<Integer> MESOS_RM_TASKS_SLOTS =
	key(ConfigConstants.TASK_MANAGER_NUM_TASK_SLOTS)
	.defaultValue(1);

public static final ConfigOption<Integer> NUM_TASK_SLOTS =
	key("taskmanager.numberOfTaskSlots")
		.defaultValue(1)
		.withDescription("...");
{code}
This pattern is problematic as this creates 2 documentation entries for {{taskmanager.numberOfTaskSlots}} with different descriptions, and opens the potential for different defaults. Ultimately this causes the documentation to become ambiguous.

I thus propose to either outright remove this option or turn it into an actual alias:
{code:java}
public static final ConfigOption<Integer> MESOS_RM_TASKS_SLOTS =
TaskManagerOptions.NUM_TASK_SLOTS;
{code}
As a side-effect of FLINK-8683 we can ensure that no differing config options exist for a given key.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)