You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "David Smiley (JIRA)" <ji...@apache.org> on 2012/06/17 21:33:42 UTC

[jira] [Commented] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs

    [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13393591#comment-13393591 ] 

David Smiley commented on SOLR-3313:
------------------------------------

I'm seeing numerous usages of "query type" as a reference to the query parser too :-(   Ugh.  I'll clean those up to be "query parser" or similar based on context.  An example in QParser.getParser()  (my emphasis added with bold):

BEFORE:{quote}
  Create a <code>QParser</code> to parse <code>qstr</code>,
  assuming that the default *query type* is <code>*defaultType*</code>.
  The *query type* may be overridden by local parameters in the query
  string itself.  For example if *defaultType*=<code>"dismax"</code>
  and qstr=<code>foo</code>, then the dismax query parser will be used
  to parse and construct the query object.  However
  if qstr=<code>\{!prefix f=myfield}foo</code>
  then the prefix query parser will be used.

  public static QParser getParser(String qstr, String *defaultType*, SolrQueryRequest req) throws ParseException
{quote}
AFTER: {quote}
  Create a <code>QParser</code> to parse <code>qstr</code>,
  assuming that the default *query parser* is <code>*defaultParser*</code>.
  The *query parser* may be overridden by local parameters in the query
  string itself.  For example if *defaultParser*=<code>"dismax"</code>
  and qstr=<code>foo</code>, then the dismax query parser will be used
  to parse and construct the query object.  However
  if qstr=<code>\{!prefix f=myfield}foo</code>
  then the prefix query parser will be used.

  public static QParser getParser(String qstr, String *defaultParser*, SolrQueryRequest req) throws ParseException
{quote}
                
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org