You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Benjamin Lerer (Jira)" <ji...@apache.org> on 2022/11/22 17:20:00 UTC

[jira] [Updated] (CASSANDRA-17221) Add Math functions

     [ https://issues.apache.org/jira/browse/CASSANDRA-17221?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Benjamin Lerer updated CASSANDRA-17221:
---------------------------------------
    Status: Ready to Commit  (was: Review In Progress)

> Add Math functions 
> -------------------
>
>                 Key: CASSANDRA-17221
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-17221
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: CQL/Syntax
>            Reporter: Benjamin Lerer
>            Assignee: Simon Chess
>            Priority: Normal
>              Labels: AdventCalendar2021, lhf
>             Fix For: 4.x
>
>          Time Spent: 1h 20m
>  Remaining Estimate: 0h
>
> We should add native Maths functions for the most common operations:
> * {{abs\(x)}} returns the absolute value of the x
> * {{exp\(x)}} returns the value of e (the base of natural logarithms) raised to the power of x
> * {{log\(x)}} returns the natural logarithm (base e) of x
> * {{log10\(x)}} returns the base-10 logarithm of x
> * {{round\(x)}} returns the closest integer to x
> +Additional information for newcomers:+
> The new functions should be put in a new class {{MathFcts}} similar to {{TimeFcts}}.
> The {{MathsFcts.all()}} method should be called in {{SystemKeyspace.functions}}
> The unit tests for the functions should be put in a {{MathFctsTest}} similar to {{TimeFctsTest}} 



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org