You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ant.apache.org by bu...@apache.org on 2004/12/02 22:55:24 UTC

DO NOT REPLY [Bug 32501] New: - [PATCH] Use File.createTempFile wherever appropriate

DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG�
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=32501>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND�
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=32501

           Summary: [PATCH] Use File.createTempFile wherever appropriate
           Product: Ant
           Version: 1.7Alpha (nightly)
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: minor
          Priority: P3
         Component: Core
        AssignedTo: jglick@netbeans.org
        ReportedBy: jglick@netbeans.org
                CC: dev@ant.apache.org


Partial deprecation of FileUtils.createTempFile, in the spirit of using standard
Java APIs whenever they suffice, for both readability and maintainability.

Also using the default ${java.io.tmpdir} rather than getProject().getBaseDir()
in AbstractMetamataTask (no documented change) and JUnitTask (change of
documented default), both to avoid leaving crud in a project directory in case
the Ant process is killed, and to avoid problems in case the project directory
is read-only.

Also a change to use a particular dir (generally dir of target file) rather than
${java.io.tmpdir} in ReplaceRegExp and FixCRLF, so FileUtils.rename need not
cross drive/mount boundaries (may be more efficient). Zip and Replace were
already doing this.

I have tried to leave untouched any usages of FileUtils.createTempFile which
actually depended on the file *not* existing after the call, at least according
to my understanding of the surrounding code. This seems to be relatively uncommon.

Advance code reviews welcome.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org