You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@datasketches.apache.org by jm...@apache.org on 2024/03/07 21:02:00 UTC

(datasketches-java) branch master updated (db9b69f5 -> c5db50c2)

This is an automated email from the ASF dual-hosted git repository.

jmalkin pushed a change to branch master
in repository https://gitbox.apache.org/repos/asf/datasketches-java.git


    from db9b69f5 Merge pull request #520 from apache/tdigest
     add 2d1aecae WIP: basic data flow for bloom filter. Minimal testing, no javadocs.
     add f8c3d0fa Checks during heapify, test coverage of BitArray
     add 14696b02 Finish unit tests covering primary functionality
     add e84ab2ec add methods for estimating filter sizes
     add 55300815 checkstyle fixes
     add 9ffb2e01 ceil in suggestion methods to ensure we never fall below the target false positive prob
     add 0d941e5c fast hash versions for longs, just to test
     add 1ae5aa4e Switch to fast hashing, rename check() to query(), and add set-only call to BitArray
     add 880b4e99 Add update/updateAndQuery/query methods for other types, update test method calls
     add 0add473e set numHashes in constructor, caset type in test to avoid github error
     add ef2120b0 start adding javadocs
     add 61fdab97 fix typo
     add c4315274 Merge branch 'bloom' of github.com:apache/datasketches-java into bloom
     add 43c21376 Merge pull request #512 from jmalkin/bloom
     add 257f2430 Merge branch 'bloom' of github.com:apache/datasketches-java into bloom
     add 933fce34 finish javadocs and fix missiing return types on some methods
     add 533cb81c finish javadocs for builder class
     add f1aadaa8 Finish main filter tests, add preamble format
     add c55ea437 Test BloomFilterBuilder methods vs manually computed values from formulae
     add 40c94837 CodeQL caught a few overflow-before-cast issues
     add 12d1fa20 remove extra space
     add 275cf228 Fix max size value to properly account for header
     add c8993166 Changes mostly based on review feedback, but without modifying the review branch since changes are small and scattered
     add 528a0759 Update BitArray.java
     add 23a212bc Merge pull request #515 from apache/bloom_review_changes
     add 5bec7130 Merge branch 'master' into bloom
     add 553f9e9b (De)serialize with buffer rather than memory inside methods
     add 33a0f75a Switch to builder-only (no public constructor), update tests to use assertThrows where relevant
     add ff0d803a Remove paramter checks (and throws) from non-public constructor
     add 00bfd54b Rename creation methods, add package-info
     add 4b345525 fix typo
     new c5db50c2 Merge pull request #513 from apache/bloom

The 1 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 .../org/apache/datasketches/common/Family.java     |   8 +-
 .../datasketches/filters/bloomfilter/BitArray.java | 222 +++++++
 .../filters/bloomfilter/BloomFilter.java           | 736 +++++++++++++++++++++
 .../filters/bloomfilter/BloomFilterBuilder.java    | 148 +++++
 .../{cpc => filters}/package-info.java             |   9 +-
 .../filters/bloomfilter/BitArrayTest.java          | 153 +++++
 .../bloomfilter/BloomFilterBuilderTest.java        |  99 +++
 .../filters/bloomfilter/BloomFilterTest.java       | 337 ++++++++++
 8 files changed, 1708 insertions(+), 4 deletions(-)
 create mode 100644 src/main/java/org/apache/datasketches/filters/bloomfilter/BitArray.java
 create mode 100644 src/main/java/org/apache/datasketches/filters/bloomfilter/BloomFilter.java
 create mode 100644 src/main/java/org/apache/datasketches/filters/bloomfilter/BloomFilterBuilder.java
 copy src/main/java/org/apache/datasketches/{cpc => filters}/package-info.java (69%)
 create mode 100644 src/test/java/org/apache/datasketches/filters/bloomfilter/BitArrayTest.java
 create mode 100644 src/test/java/org/apache/datasketches/filters/bloomfilter/BloomFilterBuilderTest.java
 create mode 100644 src/test/java/org/apache/datasketches/filters/bloomfilter/BloomFilterTest.java


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@datasketches.apache.org
For additional commands, e-mail: commits-help@datasketches.apache.org


(datasketches-java) 01/01: Merge pull request #513 from apache/bloom

Posted by jm...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

jmalkin pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/datasketches-java.git

commit c5db50c2b2c2a4cb6132dd574d49413bfceed472
Merge: db9b69f5 4b345525
Author: Jon Malkin <78...@users.noreply.github.com>
AuthorDate: Thu Mar 7 13:01:54 2024 -0800

    Merge pull request #513 from apache/bloom
    
    Bloom Filter

 .../org/apache/datasketches/common/Family.java     |   8 +-
 .../datasketches/filters/bloomfilter/BitArray.java | 222 +++++++
 .../filters/bloomfilter/BloomFilter.java           | 736 +++++++++++++++++++++
 .../filters/bloomfilter/BloomFilterBuilder.java    | 148 +++++
 .../apache/datasketches/filters/package-info.java  |  27 +
 .../filters/bloomfilter/BitArrayTest.java          | 153 +++++
 .../bloomfilter/BloomFilterBuilderTest.java        |  99 +++
 .../filters/bloomfilter/BloomFilterTest.java       | 337 ++++++++++
 8 files changed, 1729 insertions(+), 1 deletion(-)


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@datasketches.apache.org
For additional commands, e-mail: commits-help@datasketches.apache.org