You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Jeff Dever <js...@sympatico.ca> on 2002/08/01 02:50:00 UTC

[vote][httpclient] rename methods that set the socket timeout to setSocketTimeout

Proposal:
1) Rename HttpConnection.setSoTimeout to be
HttpConnection.setSocketTimeout
2) Rename HttpClient.setTimeout to HttpClient.setSocketTimeout

Purpose:
To bring consistancy and clarity to the methods that set the socket
timeout.

HttpConnection.setSoTimeout was likely named that way becuase it is
basicly a pass through that calls Socket.setSoTimeout of the underlying
socket object.  This method was added in december after the alpha1
release so we should be free to change it.  Similar story for
HttpClient.setTimeout, but it was added much more recently.

Other choices would be to:
a) Change both to setSoTimeout - it is unfortunate that the underlying
socket is named this, because the name is ambiguous.  What does So mean
anyway?  So what?  Star Office? Shared Object?  I guess it means Socket,
so lets use that.
b) Change both to be setTimeout - but timeout of what?  Read the
documentation to find out it means socket.  What if we add another
timeout value for somthing else?  then we will be forced to use
setXXXTimeout and leave the inconsistant setTimeout as depricated or as
a inconsistancy.
c) do nothing - that leave the problems of a) and b) in addition to the
inconsistancy.


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>