You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@oozie.apache.org by Azrael Seoeun Park <se...@gmail.com> on 2015/07/06 05:36:06 UTC

Re: Review Request 23301: OOZIE-1918 ActionXCommand refactoring

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23301/
-----------------------------------------------------------

(Updated July 6, 2015, 3:36 a.m.)


Review request for oozie.


Changes
-------

Addressed comments.
Rebased on the lates branch.


Bugs: OOZIE-1918
    https://issues.apache.org/jira/browse/OOZIE-1918


Repository: oozie-git


Description
-------

Subclasses of ActionXCommand have some duplicated code. Refactoring make it more neat.
This patch contain:
* Renaming CompletedActionXCommand to ActionCompletedXCommand and extending ActionXCommand
* Moving some variables and methods to ActionXCommand and making it protected
* More meaningful log message : On exeucte(), actionId is duplicated so removed
* Adding handleExecutionFail() to handle ActionExcutionException during execute()


Diffs (updated)
-----

  core/src/main/java/org/apache/oozie/DagEngine.java 9061d17 
  core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java 5827387 
  core/src/main/java/org/apache/oozie/command/wf/ActionCompletedXCommand.java PRE-CREATION 
  core/src/main/java/org/apache/oozie/command/wf/ActionEndXCommand.java 4006441 
  core/src/main/java/org/apache/oozie/command/wf/ActionKillXCommand.java 33498bf 
  core/src/main/java/org/apache/oozie/command/wf/ActionStartXCommand.java e06649c 
  core/src/main/java/org/apache/oozie/command/wf/ActionXCommand.java 2616d32 
  core/src/main/java/org/apache/oozie/command/wf/CompletedActionXCommand.java bc39bce 
  core/src/test/java/org/apache/oozie/ForTestingActionExecutor.java a70dc02 
  core/src/test/java/org/apache/oozie/command/wf/TestCompletedActionXCommand.java a4f0e83 
  core/src/test/java/org/apache/oozie/event/TestEventGeneration.java 14f5294 

Diff: https://reviews.apache.org/r/23301/diff/


Testing
-------

No added new testcase.
Done manual test.


Thanks,

Azrael Seoeun Park


Re: Review Request 23301: OOZIE-1918 ActionXCommand refactoring

Posted by Jaydeep Vishwakarma <ja...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23301/#review94678
-----------------------------------------------------------



core/src/main/java/org/apache/oozie/DagEngine.java (line 332)
<https://reviews.apache.org/r/23301/#comment149283>

    Priority is not being used, use other contructor



core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java (line 82)
<https://reviews.apache.org/r/23301/#comment149284>

    Can you rename it to loadWorkflowAndActionBean. loadActionbean is missleading.



core/src/main/java/org/apache/oozie/command/wf/ActionCompletedXCommand.java (line 51)
<https://reviews.apache.org/r/23301/#comment149282>

    pririty is not being used anywhere over here, It will also misslead. We dont need it.


- Jaydeep Vishwakarma


On July 6, 2015, 3:36 a.m., Azrael Seoeun Park wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/23301/
> -----------------------------------------------------------
> 
> (Updated July 6, 2015, 3:36 a.m.)
> 
> 
> Review request for oozie.
> 
> 
> Bugs: OOZIE-1918
>     https://issues.apache.org/jira/browse/OOZIE-1918
> 
> 
> Repository: oozie-git
> 
> 
> Description
> -------
> 
> Subclasses of ActionXCommand have some duplicated code. Refactoring make it more neat.
> This patch contain:
> * Renaming CompletedActionXCommand to ActionCompletedXCommand and extending ActionXCommand
> * Moving some variables and methods to ActionXCommand and making it protected
> * More meaningful log message : On exeucte(), actionId is duplicated so removed
> * Adding handleExecutionFail() to handle ActionExcutionException during execute()
> 
> 
> Diffs
> -----
> 
>   core/src/main/java/org/apache/oozie/DagEngine.java 9061d17 
>   core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java 5827387 
>   core/src/main/java/org/apache/oozie/command/wf/ActionCompletedXCommand.java PRE-CREATION 
>   core/src/main/java/org/apache/oozie/command/wf/ActionEndXCommand.java 4006441 
>   core/src/main/java/org/apache/oozie/command/wf/ActionKillXCommand.java 33498bf 
>   core/src/main/java/org/apache/oozie/command/wf/ActionStartXCommand.java e06649c 
>   core/src/main/java/org/apache/oozie/command/wf/ActionXCommand.java 2616d32 
>   core/src/main/java/org/apache/oozie/command/wf/CompletedActionXCommand.java bc39bce 
>   core/src/test/java/org/apache/oozie/ForTestingActionExecutor.java a70dc02 
>   core/src/test/java/org/apache/oozie/command/wf/TestCompletedActionXCommand.java a4f0e83 
>   core/src/test/java/org/apache/oozie/event/TestEventGeneration.java 14f5294 
> 
> Diff: https://reviews.apache.org/r/23301/diff/
> 
> 
> Testing
> -------
> 
> No added new testcase.
> Done manual test.
> 
> 
> Thanks,
> 
> Azrael Seoeun Park
> 
>