You are viewing a plain text version of this content. The canonical link for it is here.
Posted to fop-commits@xmlgraphics.apache.org by lf...@apache.org on 2005/04/07 18:13:54 UTC

cvs commit: xml-fop/src/java/org/apache/fop/layoutmgr BlockLayoutManager.java BlockStackingLayoutManager.java BlockContainerLayoutManager.java

lfurini     2005/04/07 09:13:54

  Modified:    src/java/org/apache/fop/layoutmgr Tag:
                        Temp_KnuthStylePageBreaking BlockLayoutManager.java
                        BlockStackingLayoutManager.java
                        BlockContainerLayoutManager.java
  Log:
  Moved methods from BlockLM to BlockStackingLM, modified parameters; these methods will be used by other subclasses of BlockStackingLM.
  
  Revision  Changes    Path
  No                   revision
  No                   revision
  1.43.2.6  +33 -794   xml-fop/src/java/org/apache/fop/layoutmgr/BlockLayoutManager.java
  
  http://cvs.apache.org/viewcvs/xml-fop/src/java/org/apache/fop/layoutmgr/BlockLayoutManager.java.diff?r1=1.43.2.5&r2=1.43.2.6
  
  
  1.11.2.5  +865 -30   xml-fop/src/java/org/apache/fop/layoutmgr/BlockStackingLayoutManager.java
  
  http://cvs.apache.org/viewcvs/xml-fop/src/java/org/apache/fop/layoutmgr/BlockStackingLayoutManager.java.diff?r1=1.11.2.4&r2=1.11.2.5
  
  
  1.36.2.8  +80 -86    xml-fop/src/java/org/apache/fop/layoutmgr/BlockContainerLayoutManager.java
  
  http://cvs.apache.org/viewcvs/xml-fop/src/java/org/apache/fop/layoutmgr/BlockContainerLayoutManager.java.diff?r1=1.36.2.7&r2=1.36.2.8
  
  

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-commits-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-commits-help@xmlgraphics.apache.org


Re: cvs commit: xml-fop/src/java/org/apache/fop/layoutmgr BlockLayoutManager.java BlockStackingLayoutManager.java BlockContainerLayoutManager.java

Posted by Jeremias Maerki <de...@greenmail.ch>.
Thanks! That's very good and already makes things clearer for me!

On 08.04.2005 19:11:28 Luca Furini wrote:
> > BTW, would you do me a favor and add a more verbose explanation of
> > LayoutManager.getChangedKnuthElements(). That is one method I still
> > don't fully understand. What does "changed" mean in this context? Is
> > "getChangedKnuthElements()" really the best method name for it?
> 
> Yes, it is used in order to "vertically justify" blocks (which could
> involve change the number of lines created for some paragraphs); I'm going
> to create a wiki page to explain the meaning of these extensions and how
> they work, as you suggested some days ago.
> 
> In a few words, the elements returned by getNextKnuthElements don't
> contain LineBreakPositions, as the exact quantity of lines is not yet
> decided; after the first page breaking is performed and the number of
> lines is decided, getChangedKnuthElements is called in order to receive
> elements containing the LineBreakPositions which will be used in the
> addAreas() phase.
> 
> I agree with you that maybe it is not the best name for it ...
> 
> I hope I'll succeed in being more clear in the wiki page, anyway don't
> hesitate to ask for more information.
> 
> Regards
>     Luca



Jeremias Maerki


Re: cvs commit: xml-fop/src/java/org/apache/fop/layoutmgr BlockLayoutManager.java BlockStackingLayoutManager.java BlockContainerLayoutManager.java

Posted by Jeremias Maerki <de...@greenmail.ch>.
Luca, I'd prefer if we wouldn't have to have this many casts to Block
and BlockContainer all over the LM. Couldn't we just add methods like
getBlockFO() and getBlockContainerFO() which do the cast? I can do this
but I don't want to interfere with anything you might do in those LMs
right now.

BTW, would you do me a favor and add a more verbose explanation of
LayoutManager.getChangedKnuthElements(). That is one method I still
don't fully understand. What does "changed" mean in this context? Is
"getChangedKnuthElements()" really the best method name for it?

Thanks a lot!

On 07.04.2005 18:13:54 lfurini wrote:
> lfurini     2005/04/07 09:13:54
> 
>   Modified:    src/java/org/apache/fop/layoutmgr Tag:
>                         Temp_KnuthStylePageBreaking BlockLayoutManager.java
>                         BlockStackingLayoutManager.java
>                         BlockContainerLayoutManager.java
>   Log:
>   Moved methods from BlockLM to BlockStackingLM, modified parameters;
>   these methods will be used by other subclasses of BlockStackingLM.


Jeremias Maerki