You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@cxf.apache.org by " Bharat Savanur (JIRA)" <ji...@apache.org> on 2015/11/15 16:13:11 UTC

[jira] [Created] (CXF-6676) Incorrect Interface Method Name Generation

 Bharat Savanur created CXF-6676:
------------------------------------

             Summary: Incorrect Interface Method Name Generation
                 Key: CXF-6676
                 URL: https://issues.apache.org/jira/browse/CXF-6676
             Project: CXF
          Issue Type: Bug
          Components: WS-* Components
    Affects Versions: 2.7.18
            Reporter:  Bharat Savanur


The issue is with interface name that gets generated if there is a special character in the Resource Path. For ex: 

Service Impln defn: 

@Post
@Path("get-add")
public Result add(Int a){
}

When we generate client interface using WADL (which is generated from the above service definition) , then interface name has the following structure:

@Path("get-add")
public Result postGet-add(Int a);


The above method name  violates JAVA METHOD NAMING conventions.
 which results in compilation errors.

Can you please let me know if there is a solution currently available for this.

Thanks and Regards,
Bharat Savanur



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)