You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mapreduce-issues@hadoop.apache.org by "Szilard Nemeth (JIRA)" <ji...@apache.org> on 2018/11/24 14:22:00 UTC

[jira] [Created] (MAPREDUCE-7161) Replace all MockRM submit method definitions with builder

Szilard Nemeth created MAPREDUCE-7161:
-----------------------------------------

             Summary: Replace all MockRM submit method definitions with builder
                 Key: MAPREDUCE-7161
                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-7161
             Project: Hadoop Map/Reduce
          Issue Type: Improvement
            Reporter: Szilard Nemeth
            Assignee: Szilard Nemeth


MockRM has 31 definitions of submitApp, most of them having more than acceptable number of parameters, ranging from 2 to even 22 parameters, which makes the code completely unreadable.
On top of unreadability, it's very hard to follow what RmApp will be produced for tests as they often pass a lot of empty / null values as parameters.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: mapreduce-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: mapreduce-issues-help@hadoop.apache.org