You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mod_python-dev@quetz.apache.org by "Graham Dumpleton (JIRA)" <ji...@apache.org> on 2006/03/29 06:53:20 UTC

[jira] Commented: (MODPYTHON-127) Use namespace for mod_python PythonOption settings.

    [ http://issues.apache.org/jira/browse/MODPYTHON-127?page=comments#action_12372184 ] 

Graham Dumpleton commented on MODPYTHON-127:
--------------------------------------------

Here is the list of options that I can find and some suggestions as to what they be called instead. Remember that old options will be honoured for backward compatibility with threat of them later being deprecated.

psp.py

  # class PSP

  PSPDbmCache ==> mod_python.PSP.cache_database_filename

Session.py

  # class BaseSession

  session_cookie_name ==> mod_python.BaseSession.cookie_name
  ApplicationPath ==> mod_python.BaseSession.application_path

  # class DbmSession

  session_dbm ==> mod_python.DbmSession.database_filename
  session_directory ==> mod_python.DbmSession.database_directory

  # class FileSession

  session_fast_cleanup ==> mod_python.FileSession.enable_fast_cleanup
  session_verify_cleanup ==> mod_python.FileSession.verify_session_timeout
  session_grace_period ==> mod_python.FileSession.cleanup_grace_period
  session_cleanup_time_limit ==> mod_python.FileSession.cleanup_time_limit
  session_directory ==> mod_python.FileSession.database_directory

  # class Session

  session ==> mod_python.Session.session_type

Anyone like to confirm that this is all and validate that names reasonable or suggest better names. My choices of names for FileSession, although they now have a name which is clearer to me, mean they diverge from what class initialiser variable names were. If all session types derive from BaseSession, should the existance of the BaseSession class be hidden and mod_python.Session.* be used instead of cases where list mod_python.BaseSession.*?

Note that an interesting issue deriving from making this list is that both DbmSession and FileSession use the "session_directory" option at the moment. Could a conflict arise from doing this if they are both writing to the same directory?

Feedback?

> Use namespace for mod_python PythonOption settings.
> ---------------------------------------------------
>
>          Key: MODPYTHON-127
>          URL: http://issues.apache.org/jira/browse/MODPYTHON-127
>      Project: mod_python
>         Type: Improvement
>   Components: core
>     Versions: 3.3
>     Reporter: Graham Dumpleton

>
> In the interests of avoiding name clashes, I want to push that where mod_python uses its own PythonOption settings, that they use a namespace. For example:
>     PythonOption mod_python.session_cookie_name ...
>     PythonOption mod_python.ApplicationPath ...
>     PythonOption mod_python.session_dbm ...
>     PythonOption mod_python.session_fast_cleanup ...
>     etc ....
> If appropriate for mod_python, multiple levels of naming should be used. For example, "session_fast_cleanup" is actually related to FileSession, so perhaps it should be:
>   PythonOption mod_python.Session.cookie_name ...
>   PythonOption mod_python.Session.application_path ...
>   PythonOption mod_python.DbmSession.database ...
>   PythonOption mod_python.FileSession.fast_cleanup ...
> Thus, class name is interjected as second level in name. Also would like to see final attribute name settle on lower case with underscore between distinct words.
> We can support old names in mod_python for the time being but should deprecate them.
> Any third party package developers should be strongly encouraged to also put any of their own PythonOption settings names in their own unique namespace.
> Mailing list thread where this was first proposed, and in case there were followups of interest, was:
>   http://www.modpython.org/pipermail/mod_python/2006-February/020213.html

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira