You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "David Mark Nemeskey (JIRA)" <ji...@apache.org> on 2011/06/05 15:44:47 UTC

[jira] [Created] (LUCENE-3173) Rename some classes and methods in the search package so their names describe their roles

Rename some classes and methods in the search package so their names describe their roles
-----------------------------------------------------------------------------------------

                 Key: LUCENE-3173
                 URL: https://issues.apache.org/jira/browse/LUCENE-3173
             Project: Lucene - Java
          Issue Type: Improvement
          Components: core/search
    Affects Versions: flexscoring branch
            Reporter: David Mark Nemeskey
            Assignee: David Mark Nemeskey
            Priority: Trivial


In an IRC discussion with Robert Muir, it has come up that the names of certain classes and methods in the search package do not describe the role of the class or method in question. Therefore, we propose the following name changes:
- Scorer to Matcher
- Similarity.computeWeight() to Similarity.computeStats()
- Similarity.DocScorer to Similarity.Scorer*

(*) Under consideration.

The reason for the name computeStats() is that this method will be used by the new Similarity subclasses to compute all the statistics they need, not just idf.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Updated] (LUCENE-3173) Rename some classes and methods in the search package so their names describe their roles

Posted by "David Mark Nemeskey (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCENE-3173?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

David Mark Nemeskey updated LUCENE-3173:
----------------------------------------

    Attachment: irc.log

Log of the IRC conversation.

> Rename some classes and methods in the search package so their names describe their roles
> -----------------------------------------------------------------------------------------
>
>                 Key: LUCENE-3173
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3173
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: core/search
>    Affects Versions: flexscoring branch
>            Reporter: David Mark Nemeskey
>            Assignee: David Mark Nemeskey
>            Priority: Trivial
>         Attachments: irc.log
>
>
> In an IRC discussion with Robert Muir, it has come up that the names of certain classes and methods in the search package do not describe the role of the class or method in question. Therefore, we propose the following name changes:
> - Scorer to Matcher
> - Similarity.computeWeight() to Similarity.computeStats()
> - Similarity.DocScorer to Similarity.Scorer*
> (*) Under consideration.
> The reason for the name computeStats() is that this method will be used by the new Similarity subclasses to compute all the statistics they need, not just idf.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Updated] (LUCENE-3173) Rename some classes and methods in the search package so their names describe their roles

Posted by "David Mark Nemeskey (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCENE-3173?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

David Mark Nemeskey updated LUCENE-3173:
----------------------------------------

    Description: 
In an IRC discussion with Robert Muir, it has come up that the names of certain classes and methods in the search package do not describe the role of the class or method in question. Therefore, we propose the following name changes:
- Scorer to Matcher
- Similarity.computeWeight() to Similarity.computeStats()
- Similarity.DocScorer to Similarity.Scorer*

*: Under consideration.

The reason for the name computeStats() is that this method will be used by the new Similarity subclasses to compute all the statistics they need, not just idf.

  was:
In an IRC discussion with Robert Muir, it has come up that the names of certain classes and methods in the search package do not describe the role of the class or method in question. Therefore, we propose the following name changes:
- Scorer to Matcher
- Similarity.computeWeight() to Similarity.computeStats()
- Similarity.DocScorer to Similarity.Scorer*

(*) Under consideration.

The reason for the name computeStats() is that this method will be used by the new Similarity subclasses to compute all the statistics they need, not just idf.


> Rename some classes and methods in the search package so their names describe their roles
> -----------------------------------------------------------------------------------------
>
>                 Key: LUCENE-3173
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3173
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: core/search
>    Affects Versions: flexscoring branch
>            Reporter: David Mark Nemeskey
>            Assignee: David Mark Nemeskey
>            Priority: Trivial
>         Attachments: irc.log
>
>
> In an IRC discussion with Robert Muir, it has come up that the names of certain classes and methods in the search package do not describe the role of the class or method in question. Therefore, we propose the following name changes:
> - Scorer to Matcher
> - Similarity.computeWeight() to Similarity.computeStats()
> - Similarity.DocScorer to Similarity.Scorer*
> *: Under consideration.
> The reason for the name computeStats() is that this method will be used by the new Similarity subclasses to compute all the statistics they need, not just idf.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Updated] (LUCENE-3173) Rename some classes and methods in the search package so their names describe their roles

Posted by "David Mark Nemeskey (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCENE-3173?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

David Mark Nemeskey updated LUCENE-3173:
----------------------------------------

    Issue Type: Sub-task  (was: Improvement)
        Parent: LUCENE-2959

> Rename some classes and methods in the search package so their names describe their roles
> -----------------------------------------------------------------------------------------
>
>                 Key: LUCENE-3173
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3173
>             Project: Lucene - Java
>          Issue Type: Sub-task
>          Components: core/search
>    Affects Versions: flexscoring branch
>            Reporter: David Mark Nemeskey
>            Assignee: David Mark Nemeskey
>            Priority: Trivial
>         Attachments: irc.log
>
>
> In an IRC discussion with Robert Muir, it has come up that the names of certain classes and methods in the search package do not describe the role of the class or method in question. Therefore, we propose the following name changes:
> - Scorer to Matcher
> - Similarity.computeWeight() to Similarity.computeStats()
> - Similarity.DocScorer to Similarity.Scorer*
> *: Under consideration.
> The reason for the name computeStats() is that this method will be used by the new Similarity subclasses to compute all the statistics they need, not just idf.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org