You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@flink.apache.org by zh...@apache.org on 2020/04/29 11:17:34 UTC
[flink] branch master updated (f87e120 -> 72f528d)
This is an automated email from the ASF dual-hosted git repository.
zhijiang pushed a change to branch master
in repository https://gitbox.apache.org/repos/asf/flink.git.
from f87e120 [hotfix][tests] Deduplicate code in SlotManagerImplTest
add 4a1363f [hotfix][network] Rename ResultPartitionWriter#initializeState to #readRecoveredState
add 59ae237 [hotfix][checkpointing] Use practical ChannelStateReader instead of NO_OP
add 72f528d [FLINK-17440][network] Resolve potential buffer leak in output unspilling for unaligned checkpoints
No new revisions were added by this update.
Summary of changes:
.../network/api/writer/ResultPartitionWriter.java | 4 +-
.../network/partition/PipelinedSubpartition.java | 24 ++++++----
.../io/network/partition/ResultPartition.java | 4 +-
.../io/network/partition/ResultSubpartition.java | 2 +-
...bleNotifyingResultPartitionWriterDecorator.java | 4 +-
.../io/network/api/writer/RecordWriterTest.java | 2 +-
.../partition/MockResultPartitionWriter.java | 2 +-
.../io/network/partition/ResultPartitionTest.java | 51 +++++++++++++++++++++-
.../flink/streaming/runtime/tasks/StreamTask.java | 4 +-
.../streaming/runtime/tasks/StreamTaskTest.java | 2 +-
10 files changed, 75 insertions(+), 24 deletions(-)