You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tinkerpop.apache.org by jbmusso <gi...@git.apache.org> on 2015/10/16 00:32:52 UTC

[GitHub] incubator-tinkerpop pull request: Enhance match()-step and where()...

GitHub user jbmusso opened a pull request:

    https://github.com/apache/incubator-tinkerpop/pull/108

    Enhance match()-step and where()-step documentation

    Result from the Gremlin console for the added `match()`-step query:
    ```groovy
    :> g.V().match(__.as('creators').out('created').has('name', 'lop').as('projects'),__.as('projects').in('created').has('age', 29).as('cocreators')).select('creators','cocreators').by('name')
    ==>{creators=marko, cocreators=marko}
    ==>{creators=josh, cocreators=marko}
    ==>{creators=peter, cocreators=marko}
    ```

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/jbmusso/incubator-tinkerpop doc-steps

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/incubator-tinkerpop/pull/108.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #108
    
----
commit 961537090f2441f2faf091d5ac7c3da5fec2b77d
Author: jbmusso <jb...@gmail.com>
Date:   2015-10-15T22:09:48Z

    Update match()-step documentation with domain-related as() step labels

commit 61002265a57a722bb54251c10a272799baf9c9d6
Author: jbmusso <jb...@gmail.com>
Date:   2015-10-15T22:12:38Z

    Flag OLAP warning limitation as temporary in where()-step documentation

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

[GitHub] incubator-tinkerpop pull request: Enhance match()-step and where()...

Posted by asfgit <gi...@git.apache.org>.
Github user asfgit closed the pull request at:

    https://github.com/apache/incubator-tinkerpop/pull/108


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

[GitHub] incubator-tinkerpop pull request: Enhance match()-step and where()...

Posted by okram <gi...@git.apache.org>.
Github user okram commented on the pull request:

    https://github.com/apache/incubator-tinkerpop/pull/108#issuecomment-148549176
  
    Given that this is such a minor change, I will merge to `tp30` and declare CTR.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---