You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mahout.apache.org by "Suneel Marthi (JIRA)" <ji...@apache.org> on 2014/01/09 21:59:50 UTC

[jira] [Commented] (MAHOUT-1393) Removed duplicated code from getTopTerms and getTopFeatures in AbstractClusterWriter

    [ https://issues.apache.org/jira/browse/MAHOUT-1393?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13867042#comment-13867042 ] 

Suneel Marthi commented on MAHOUT-1393:
---------------------------------------

Thanks for submitting this patch. Have you tried compiling this atleast once? Your patch is just not gonna compile.

> Removed duplicated code from getTopTerms and getTopFeatures in AbstractClusterWriter 
> -------------------------------------------------------------------------------------
>
>                 Key: MAHOUT-1393
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-1393
>             Project: Mahout
>          Issue Type: Improvement
>          Components: Clustering
>            Reporter: Diego Carrion
>            Priority: Minor
>              Labels: cluster, dumper, term, top
>         Attachments: refactoring.patch
>
>
> The class org.apache.mahout.utils.clusteringAbstractClusterWriterTest has duplicated code in the methods getTopFeatures and getTopTerms. The duplicated code was extracted to a third private method called getTopTermsPairs.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)