You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Sun Rui (JIRA)" <ji...@apache.org> on 2016/03/18 04:33:33 UTC

[jira] [Commented] (SPARK-12148) SparkR: rename DataFrame to SparkDataFrame

    [ https://issues.apache.org/jira/browse/SPARK-12148?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15200940#comment-15200940 ] 

Sun Rui commented on SPARK-12148:
---------------------------------

An issue reported in the Spark user list may be related to this naming conflict.
{code}
countData <- matrix(1:100,ncol=4)
condition <- factor(c("A","A","B","B"))
dds <- DESeqDataSetFromMatrix(countData, DataFrame(condition), ~ condition)

Works if i dont initialize the sparkR environment. 
 if I do library(SparkR) and sqlContext <- sparkRSQL.init(sc)  it gives following error 

> dds <- DESeqDataSetFromMatrix(countData, as.data.frame(condition), ~ condition)
Error in DataFrame(colData, row.names = rownames(colData)) : 
  cannot coerce class "data.frame" to a DataFrame
{code}

> SparkR: rename DataFrame to SparkDataFrame
> ------------------------------------------
>
>                 Key: SPARK-12148
>                 URL: https://issues.apache.org/jira/browse/SPARK-12148
>             Project: Spark
>          Issue Type: Sub-task
>          Components: SparkR
>            Reporter: Michael Lawrence
>
> The SparkR package represents a Spark DataFrame with the class "DataFrame". That conflicts with the more general DataFrame class defined in the S4Vectors package. Would it not be more appropriate to use the name "SparkDataFrame" instead?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org