You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ranger.apache.org by "Madhan Neethiraj (JIRA)" <ji...@apache.org> on 2016/03/09 00:29:40 UTC

[jira] [Created] (RANGER-880) Good coding practice: inner class to be made static; wait() should be in a loop

Madhan Neethiraj created RANGER-880:
---------------------------------------

             Summary: Good coding practice: inner class to be made static; wait() should be in a loop
                 Key: RANGER-880
                 URL: https://issues.apache.org/jira/browse/RANGER-880
             Project: Ranger
          Issue Type: Bug
          Components: tagsync
    Affects Versions: 0.6.0
            Reporter: Madhan Neethiraj
            Assignee: Madhan Neethiraj
             Fix For: 0.6.0


1) Inner class TagAdminRESTSink.UploadWorkItem should be made static - as it doesn't need access to enclosing class members.
2) .wait() method should be called within a loop - to handle possible interrupts and spurious wakes - see Java doc for Object.wait() for details.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)