You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Dmitriy Pavlov (JIRA)" <ji...@apache.org> on 2018/04/20 15:26:00 UTC

[jira] [Commented] (IGNITE-6260) Need to rename setDistributedJoins to setNonCollocatedJoins

    [ https://issues.apache.org/jira/browse/IGNITE-6260?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16445891#comment-16445891 ] 

Dmitriy Pavlov commented on IGNITE-6260:
----------------------------------------

Folks, ticket is in PA state and there is no activity since 2017. Should we accept or reject patch?

> Need to rename setDistributedJoins to setNonCollocatedJoins
> -----------------------------------------------------------
>
>                 Key: IGNITE-6260
>                 URL: https://issues.apache.org/jira/browse/IGNITE-6260
>             Project: Ignite
>          Issue Type: Improvement
>          Components: jdbc, odbc, sql
>            Reporter: Dmitriy Setrakyan
>            Assignee: vk
>            Priority: Major
>              Labels: usability
>
> The name {{distributed join}} is very confusing, as all joins in Ignite are distributed. We should do the following:
> * Deprecate {{setDistributedJoins(...)}} property (it should be removed in 3.0)
> * Add {{setNonCollocatedJoins(...)}} property.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)