You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@beam.apache.org by "Aljoscha Krettek (JIRA)" <ji...@apache.org> on 2016/07/18 14:10:20 UTC
[jira] [Assigned] (BEAM-253) Unify Flink Operator Wrappers
[ https://issues.apache.org/jira/browse/BEAM-253?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Aljoscha Krettek reassigned BEAM-253:
-------------------------------------
Assignee: Aljoscha Krettek
> Unify Flink Operator Wrappers
> -----------------------------
>
> Key: BEAM-253
> URL: https://issues.apache.org/jira/browse/BEAM-253
> Project: Beam
> Issue Type: Improvement
> Components: runner-flink
> Reporter: Aljoscha Krettek
> Assignee: Aljoscha Krettek
>
> Right now, we have {{FlinkAbstractParDoWrapper}} with subclasses {{FlinkParDoBoundWrapper}} and {{FlinkParDoBoundMultiWrapper}} as well as {{FlinkGroupAlsoByWindowWrapper}}. They do essentially the same thing, but slightly differently. The first three are implemented as a {{FlatMapFunction}} while the latter is implemented as a {{StreamOperator}} (which is more low-level and gives access to state and timers and such).
> We should unify this into one wrapper. (With possibly a more concise name...)
> In the process of this we should also make sure that we always use a {{DoFnRunner}} via {{DoFnRunners.createDefault}}. This will help reduce bugs such as [BEAM-241].
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)