You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@kafka.apache.org by Guozhang Wang <wa...@gmail.com> on 2015/05/18 23:07:59 UTC
Re: Review Request 34283: Third Attempt: use a global read-write lock
in purgatory; remove join-group purgatory from coordinator
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34283/
-----------------------------------------------------------
(Updated May 18, 2015, 9:07 p.m.)
Review request for kafka.
Summary (updated)
-----------------
Third Attempt: use a global read-write lock in purgatory; remove join-group purgatory from coordinator
Bugs: KAFKA-2160
https://issues.apache.org/jira/browse/KAFKA-2160
Repository: kafka
Description
-------
Fix KAFKA-2160
Diffs (updated)
-----
core/src/main/scala/kafka/coordinator/ConsumerCoordinator.scala 6f05488bd3bf7ff81f07ff27b9b23f8a8d45ce58
core/src/main/scala/kafka/coordinator/CoordinatorMetadata.scala 88e82b66060f17223a023c743ff00ae53de4834b
core/src/main/scala/kafka/coordinator/DelayedHeartbeat.scala b3360cc29a10adf6b01bdcbbe90baa4aedc42bf7
core/src/main/scala/kafka/coordinator/DelayedJoinGroup.scala 8f57d388c2f1093b8e1b7b4560853419094402bf
core/src/main/scala/kafka/coordinator/DelayedRebalance.scala 689621c5cb95f5b5d9c70dfc4a098d1c1fa7a818
core/src/main/scala/kafka/coordinator/Group.scala 048eeee4586acf74a8252591a318d0ba588b9ca9
core/src/main/scala/kafka/coordinator/HeartbeatBucket.scala b6b9f5f11d6b23f1f627ee85097c22735194ed90
core/src/main/scala/kafka/server/DelayedOperation.scala 2ed9b467c2865e5717d7f6fd933cd09a5c5b22c0
core/src/test/scala/other/kafka/TestPurgatoryPerformance.scala 39d6d8a0939202be88eaaf63b250f11d79200ca6
core/src/test/scala/unit/kafka/coordinator/GroupTest.scala 6561a1da5fca4b0c9e11c9e5417eb0497de11c42
Diff: https://reviews.apache.org/r/34283/diff/
Testing
-------
Thanks,
Guozhang Wang
Re: Review Request 34283: Third Attempt: use a global read-write lock
in purgatory; remove join-group purgatory from coordinator
Posted by Jun Rao <ju...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34283/#review84424
-----------------------------------------------------------
Ship it!
Thanks for the patch. Looks good to me. Just a few minor comments below.
core/src/main/scala/kafka/server/DelayedOperation.scala
<https://reviews.apache.org/r/34283/#comment135672>
remove.
core/src/main/scala/kafka/server/DelayedOperation.scala
<https://reviews.apache.org/r/34283/#comment135673>
To make it clear, would it better to name this removeWatchersLock?
core/src/main/scala/kafka/server/DelayedOperation.scala
<https://reviews.apache.org/r/34283/#comment135674>
Perhaps we can rename this to removeKeyIfEmpty?
- Jun Rao
On May 18, 2015, 9:08 p.m., Guozhang Wang wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/34283/
> -----------------------------------------------------------
>
> (Updated May 18, 2015, 9:08 p.m.)
>
>
> Review request for kafka.
>
>
> Bugs: KAFKA-2160
> https://issues.apache.org/jira/browse/KAFKA-2160
>
>
> Repository: kafka
>
>
> Description
> -------
>
> Fix KAFKA-2160
>
>
> Diffs
> -----
>
> core/src/main/scala/kafka/coordinator/ConsumerCoordinator.scala 6f05488bd3bf7ff81f07ff27b9b23f8a8d45ce58
> core/src/main/scala/kafka/coordinator/CoordinatorMetadata.scala 88e82b66060f17223a023c743ff00ae53de4834b
> core/src/main/scala/kafka/coordinator/DelayedHeartbeat.scala b3360cc29a10adf6b01bdcbbe90baa4aedc42bf7
> core/src/main/scala/kafka/coordinator/DelayedJoinGroup.scala 8f57d388c2f1093b8e1b7b4560853419094402bf
> core/src/main/scala/kafka/coordinator/DelayedRebalance.scala 689621c5cb95f5b5d9c70dfc4a098d1c1fa7a818
> core/src/main/scala/kafka/coordinator/Group.scala 048eeee4586acf74a8252591a318d0ba588b9ca9
> core/src/main/scala/kafka/coordinator/HeartbeatBucket.scala b6b9f5f11d6b23f1f627ee85097c22735194ed90
> core/src/main/scala/kafka/server/DelayedOperation.scala 2ed9b467c2865e5717d7f6fd933cd09a5c5b22c0
> core/src/test/scala/other/kafka/TestPurgatoryPerformance.scala 39d6d8a0939202be88eaaf63b250f11d79200ca6
> core/src/test/scala/unit/kafka/coordinator/GroupTest.scala 6561a1da5fca4b0c9e11c9e5417eb0497de11c42
>
> Diff: https://reviews.apache.org/r/34283/diff/
>
>
> Testing
> -------
>
> Unit tests.
>
>
> Thanks,
>
> Guozhang Wang
>
>
Re: Review Request 34283: Third Attempt: use a global read-write lock
in purgatory; remove join-group purgatory from coordinator
Posted by Guozhang Wang <wa...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34283/
-----------------------------------------------------------
(Updated May 18, 2015, 9:08 p.m.)
Review request for kafka.
Bugs: KAFKA-2160
https://issues.apache.org/jira/browse/KAFKA-2160
Repository: kafka
Description
-------
Fix KAFKA-2160
Diffs
-----
core/src/main/scala/kafka/coordinator/ConsumerCoordinator.scala 6f05488bd3bf7ff81f07ff27b9b23f8a8d45ce58
core/src/main/scala/kafka/coordinator/CoordinatorMetadata.scala 88e82b66060f17223a023c743ff00ae53de4834b
core/src/main/scala/kafka/coordinator/DelayedHeartbeat.scala b3360cc29a10adf6b01bdcbbe90baa4aedc42bf7
core/src/main/scala/kafka/coordinator/DelayedJoinGroup.scala 8f57d388c2f1093b8e1b7b4560853419094402bf
core/src/main/scala/kafka/coordinator/DelayedRebalance.scala 689621c5cb95f5b5d9c70dfc4a098d1c1fa7a818
core/src/main/scala/kafka/coordinator/Group.scala 048eeee4586acf74a8252591a318d0ba588b9ca9
core/src/main/scala/kafka/coordinator/HeartbeatBucket.scala b6b9f5f11d6b23f1f627ee85097c22735194ed90
core/src/main/scala/kafka/server/DelayedOperation.scala 2ed9b467c2865e5717d7f6fd933cd09a5c5b22c0
core/src/test/scala/other/kafka/TestPurgatoryPerformance.scala 39d6d8a0939202be88eaaf63b250f11d79200ca6
core/src/test/scala/unit/kafka/coordinator/GroupTest.scala 6561a1da5fca4b0c9e11c9e5417eb0497de11c42
Diff: https://reviews.apache.org/r/34283/diff/
Testing (updated)
-------
Unit tests.
Thanks,
Guozhang Wang