You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@jackrabbit.apache.org by "Jukka Zitting (JIRA)" <ji...@apache.org> on 2006/09/11 09:33:22 UTC

[jira] Created: (JCR-565) Refactor ObservationManagerFactory

Refactor ObservationManagerFactory
----------------------------------

                 Key: JCR-565
                 URL: http://issues.apache.org/jira/browse/JCR-565
             Project: Jackrabbit
          Issue Type: Improvement
          Components: observation
            Reporter: Jukka Zitting
            Priority: Minor


The current o.a.j.core.observation.ObservationManagerFactory class has two main responsibilities:

    1) Create new ObservationManagerImpl instances as an observation manager factory
    2) Manage event consumers and dispatch events within a workspace

These two responsibilities are quite unrelated and the factory responsibility essentially boils down to the following method that is only ever invoked within WorkspaceImpl.getObservationManager():

    public ObservationManagerImpl createObservationManager(SessionImpl session, ItemManager itemMgr) {
        return new ObservationManagerImpl(this, session, itemMgr);
    }

To simplify the design I'd inline this method and rename ObservationManagerFactory to ObservationDispatcher to better reflect the one remaining responsibility.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Updated: (JCR-565) Refactor ObservationManagerFactory

Posted by "Jukka Zitting (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/JCR-565?page=all ]

Jukka Zitting updated JCR-565:
------------------------------

    Attachment: dispatcher.patch

Attached a patch that performs this refactoring. I'll apply it unless anyone objects within a few days.

> Refactor ObservationManagerFactory
> ----------------------------------
>
>                 Key: JCR-565
>                 URL: http://issues.apache.org/jira/browse/JCR-565
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: observation
>            Reporter: Jukka Zitting
>            Priority: Minor
>         Attachments: dispatcher.patch
>
>
> The current o.a.j.core.observation.ObservationManagerFactory class has two main responsibilities:
>     1) Create new ObservationManagerImpl instances as an observation manager factory
>     2) Manage event consumers and dispatch events within a workspace
> These two responsibilities are quite unrelated and the factory responsibility essentially boils down to the following method that is only ever invoked within WorkspaceImpl.getObservationManager():
>     public ObservationManagerImpl createObservationManager(SessionImpl session, ItemManager itemMgr) {
>         return new ObservationManagerImpl(this, session, itemMgr);
>     }
> To simplify the design I'd inline this method and rename ObservationManagerFactory to ObservationDispatcher to better reflect the one remaining responsibility.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Resolved: (JCR-565) Refactor ObservationManagerFactory

Posted by "Jukka Zitting (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/JCR-565?page=all ]

Jukka Zitting resolved JCR-565.
-------------------------------

    Fix Version/s: 1.1
       Resolution: Fixed
         Assignee: Jukka Zitting

Suggested changes applied in revision 446866.

> Refactor ObservationManagerFactory
> ----------------------------------
>
>                 Key: JCR-565
>                 URL: http://issues.apache.org/jira/browse/JCR-565
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: observation
>            Reporter: Jukka Zitting
>         Assigned To: Jukka Zitting
>            Priority: Minor
>             Fix For: 1.1
>
>         Attachments: dispatcher.patch
>
>
> The current o.a.j.core.observation.ObservationManagerFactory class has two main responsibilities:
>     1) Create new ObservationManagerImpl instances as an observation manager factory
>     2) Manage event consumers and dispatch events within a workspace
> These two responsibilities are quite unrelated and the factory responsibility essentially boils down to the following method that is only ever invoked within WorkspaceImpl.getObservationManager():
>     public ObservationManagerImpl createObservationManager(SessionImpl session, ItemManager itemMgr) {
>         return new ObservationManagerImpl(this, session, itemMgr);
>     }
> To simplify the design I'd inline this method and rename ObservationManagerFactory to ObservationDispatcher to better reflect the one remaining responsibility.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira