You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@jena.apache.org by "A. Soroka (JIRA)" <ji...@apache.org> on 2015/11/23 14:54:11 UTC

[jira] [Comment Edited] (JENA-1074) Add find operations for DatasetGraph for the union graph.

    [ https://issues.apache.org/jira/browse/JENA-1074?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15022115#comment-15022115 ] 

A. Soroka edited comment on JENA-1074 at 11/23/15 1:53 PM:
-----------------------------------------------------------

Is it absolutely necessary for a {{DatasetGraph}} to support union graph? I'm no expert on the standards, but the way I understand the dataset concept, there is no restriction that the number of named graphs be finite. In more practical terms, I could imagine impl'ing {{DatasetGraph}} over some kind of persistence where it would be horribly expensive or even truly impossible to iterate over all the graphs.


was (Author: ajs6f):
Is it absolutely necessary for a `DatasetGraph` to support union graph? I'm no expert on the standards, but the way I understand the dataset concept, there is no restriction that the number of named graphs be finite. In more practical terms, I could imagine impl'ing `DatasetGraph` over some kind of persistence where it would be horribly expensive or even truly impossible to iterate over all the graphs.

> Add find operations for DatasetGraph for the union graph.
> ---------------------------------------------------------
>
>                 Key: JENA-1074
>                 URL: https://issues.apache.org/jira/browse/JENA-1074
>             Project: Apache Jena
>          Issue Type: Brainstorming
>          Components: ARQ
>    Affects Versions: Jena 3.0.0
>            Reporter: Andy Seaborne
>            Priority: Minor
>
> (This follows on from JENA-1064)
> {{DatasetGraphBaseFind}} now has a {{find}} operations for the union graph added to make implementation easier.
> Should operation(s) be exposed in the core interface {{DatasetGraph}} (the application contract)? If so, how?
> The operations to consider include:
> * {{findInUnionGraph}} ({{Iterator<Triple>}})
> * {{findQuadsInUnionGraph}} ({{Iterator<Quad>}})
> * {{findInDftGraph}} ({{Iterator<Quad>}} - inconsistent naming with above)
> At the moment {{findInDftGraph}} returns quads and documents {{DatasetGraph.getDefaultGraph().find()}} as being the way to get triples. This suggests a different style where {{DatasetGraph}} has:
> * {{DatasetGraph.getUnionGraph()}}
> * {{DatasetGraphFind.findInUnionGraph}} ({{Iterator<Quad>}})



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)