You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@camel.apache.org by "Claus Ibsen (Jira)" <ji...@apache.org> on 2024/12/29 17:29:00 UTC

[jira] [Comment Edited] (CAMEL-17648) Optimizing File component performance when filtering file names.

    [ https://issues.apache.org/jira/browse/CAMEL-17648?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17908726#comment-17908726 ] 

Claus Ibsen edited comment on CAMEL-17648 at 12/29/24 5:28 PM:
---------------------------------------------------------------

TODO: include/exclude *DONE*

TODO: antInclude/antExclude: *DONE*

TODO: file filter *DONE*

 


was (Author: davsclaus):
TODO: include/exclude *DONE*

TODO: antInclude/antExclude: *DONE*

TODO: file filter

 

> Optimizing File component performance when filtering file names.
> ----------------------------------------------------------------
>
>                 Key: CAMEL-17648
>                 URL: https://issues.apache.org/jira/browse/CAMEL-17648
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-file
>            Reporter: Ja
>            Assignee: Claus Ibsen
>            Priority: Major
>             Fix For: 4.10.0
>
>         Attachments: CAMEL-17648.patch
>
>
> Currently FileConsumer matches file names after creating GenericFile object for each file witch can be time consuming especially in shared network directories.
> This could be optimized by matching on name based query parameters (fileName, include, exclude, antExclude, antInclude, includeExt, excludeExt) before creating GenericFile objects.
> If the file name does not match creating GenericFile objects would not be necessary.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)