You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Todd Lipcon (JIRA)" <ji...@apache.org> on 2011/05/06 02:28:03 UTC
[jira] [Created] (HDFS-1899) GenericTestUtils.formatNameNode is
misplaced
GenericTestUtils.formatNameNode is misplaced
--------------------------------------------
Key: HDFS-1899
URL: https://issues.apache.org/jira/browse/HDFS-1899
Project: Hadoop HDFS
Issue Type: Improvement
Affects Versions: 0.23.0
Reporter: Todd Lipcon
Fix For: 0.23.0
This function belongs in DFSTestUtil, the standard place for putting cluster-related utils.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Commented] (HDFS-1899) GenericTestUtils.formatNamenode is
misplaced
Posted by "Hudson (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HDFS-1899?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13034567#comment-13034567 ]
Hudson commented on HDFS-1899:
------------------------------
Integrated in Hadoop-Hdfs-trunk-Commit #658 (See [https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/658/])
> GenericTestUtils.formatNamenode is misplaced
> --------------------------------------------
>
> Key: HDFS-1899
> URL: https://issues.apache.org/jira/browse/HDFS-1899
> Project: Hadoop HDFS
> Issue Type: Improvement
> Affects Versions: 0.23.0
> Reporter: Todd Lipcon
> Assignee: Ted Yu
> Labels: newbie
> Fix For: 0.23.0
>
> Attachments: HDFS-1899.patch
>
>
> This function belongs in DFSTestUtil, the standard place for putting cluster-related utils.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Updated] (HDFS-1899) GenericTestUtils.formatNamenode is
misplaced
Posted by "Todd Lipcon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HDFS-1899?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Todd Lipcon updated HDFS-1899:
------------------------------
Summary: GenericTestUtils.formatNamenode is misplaced (was: GenericTestUtils.formatNameNode is misplaced)
also, it should be renamed to formatNameNode, not formatNamenode for consistent capitalization.
> GenericTestUtils.formatNamenode is misplaced
> --------------------------------------------
>
> Key: HDFS-1899
> URL: https://issues.apache.org/jira/browse/HDFS-1899
> Project: Hadoop HDFS
> Issue Type: Improvement
> Affects Versions: 0.23.0
> Reporter: Todd Lipcon
> Fix For: 0.23.0
>
>
> This function belongs in DFSTestUtil, the standard place for putting cluster-related utils.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Commented] (HDFS-1899) GenericTestUtils.formatNamenode is
misplaced
Posted by "Hudson (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HDFS-1899?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13037316#comment-13037316 ]
Hudson commented on HDFS-1899:
------------------------------
Integrated in Hadoop-Hdfs-trunk #673 (See [https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk/673/])
> GenericTestUtils.formatNamenode is misplaced
> --------------------------------------------
>
> Key: HDFS-1899
> URL: https://issues.apache.org/jira/browse/HDFS-1899
> Project: Hadoop HDFS
> Issue Type: Improvement
> Affects Versions: 0.23.0
> Reporter: Todd Lipcon
> Assignee: Ted Yu
> Labels: newbie
> Fix For: 0.23.0
>
> Attachments: HDFS-1899.patch
>
>
> This function belongs in DFSTestUtil, the standard place for putting cluster-related utils.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Updated] (HDFS-1899) GenericTestUtils.formatNamenode is
misplaced
Posted by "Ted Yu (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HDFS-1899?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Ted Yu updated HDFS-1899:
-------------------------
Attachment: HDFS-1899.patch
Moved formatNameNode() to DFSTestUtil
> GenericTestUtils.formatNamenode is misplaced
> --------------------------------------------
>
> Key: HDFS-1899
> URL: https://issues.apache.org/jira/browse/HDFS-1899
> Project: Hadoop HDFS
> Issue Type: Improvement
> Affects Versions: 0.23.0
> Reporter: Todd Lipcon
> Labels: newbie
> Fix For: 0.23.0
>
> Attachments: HDFS-1899.patch
>
>
> This function belongs in DFSTestUtil, the standard place for putting cluster-related utils.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Updated] (HDFS-1899) GenericTestUtils.formatNamenode is
misplaced
Posted by "Todd Lipcon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HDFS-1899?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Todd Lipcon updated HDFS-1899:
------------------------------
Status: Patch Available (was: Open)
> GenericTestUtils.formatNamenode is misplaced
> --------------------------------------------
>
> Key: HDFS-1899
> URL: https://issues.apache.org/jira/browse/HDFS-1899
> Project: Hadoop HDFS
> Issue Type: Improvement
> Affects Versions: 0.23.0
> Reporter: Todd Lipcon
> Assignee: Ted Yu
> Labels: newbie
> Fix For: 0.23.0
>
> Attachments: HDFS-1899.patch
>
>
> This function belongs in DFSTestUtil, the standard place for putting cluster-related utils.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Updated] (HDFS-1899) GenericTestUtils.formatNamenode is
misplaced
Posted by "Todd Lipcon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HDFS-1899?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Todd Lipcon updated HDFS-1899:
------------------------------
Resolution: Fixed
Hadoop Flags: [Reviewed]
Status: Resolved (was: Patch Available)
Committed to trunk. Thanks, Ted!
> GenericTestUtils.formatNamenode is misplaced
> --------------------------------------------
>
> Key: HDFS-1899
> URL: https://issues.apache.org/jira/browse/HDFS-1899
> Project: Hadoop HDFS
> Issue Type: Improvement
> Affects Versions: 0.23.0
> Reporter: Todd Lipcon
> Assignee: Ted Yu
> Labels: newbie
> Fix For: 0.23.0
>
> Attachments: HDFS-1899.patch
>
>
> This function belongs in DFSTestUtil, the standard place for putting cluster-related utils.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Commented] (HDFS-1899) GenericTestUtils.formatNamenode is
misplaced
Posted by "Hadoop QA (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HDFS-1899?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13032913#comment-13032913 ]
Hadoop QA commented on HDFS-1899:
---------------------------------
-1 overall. Here are the results of testing the latest attachment
http://issues.apache.org/jira/secure/attachment/12478847/HDFS-1899.patch
against trunk revision 1102513.
+1 @author. The patch does not contain any @author tags.
+1 tests included. The patch appears to include 36 new or modified tests.
+1 javadoc. The javadoc tool did not generate any warning messages.
+1 javac. The applied patch does not increase the total number of javac compiler warnings.
+1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.
+1 release audit. The applied patch does not increase the total number of release audit warnings.
-1 core tests. The patch failed these core unit tests:
org.apache.hadoop.cli.TestHDFSCLI
org.apache.hadoop.hdfs.TestDFSClientRetries
org.apache.hadoop.hdfs.TestDFSStorageStateRecovery
org.apache.hadoop.hdfs.TestFileConcurrentReader
org.apache.hadoop.tools.TestJMXGet
+1 contrib tests. The patch passed contrib unit tests.
+1 system test framework. The patch passed system test framework compile.
Test results: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/513//testReport/
Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/513//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Console output: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/513//console
This message is automatically generated.
> GenericTestUtils.formatNamenode is misplaced
> --------------------------------------------
>
> Key: HDFS-1899
> URL: https://issues.apache.org/jira/browse/HDFS-1899
> Project: Hadoop HDFS
> Issue Type: Improvement
> Affects Versions: 0.23.0
> Reporter: Todd Lipcon
> Assignee: Ted Yu
> Labels: newbie
> Fix For: 0.23.0
>
> Attachments: HDFS-1899.patch
>
>
> This function belongs in DFSTestUtil, the standard place for putting cluster-related utils.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Assigned] (HDFS-1899) GenericTestUtils.formatNamenode is
misplaced
Posted by "Ted Yu (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HDFS-1899?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Ted Yu reassigned HDFS-1899:
----------------------------
Assignee: Ted Yu
> GenericTestUtils.formatNamenode is misplaced
> --------------------------------------------
>
> Key: HDFS-1899
> URL: https://issues.apache.org/jira/browse/HDFS-1899
> Project: Hadoop HDFS
> Issue Type: Improvement
> Affects Versions: 0.23.0
> Reporter: Todd Lipcon
> Assignee: Ted Yu
> Labels: newbie
> Fix For: 0.23.0
>
> Attachments: HDFS-1899.patch
>
>
> This function belongs in DFSTestUtil, the standard place for putting cluster-related utils.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira