You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hive.apache.org by "Thomas Rebele (Jira)" <ji...@apache.org> on 2026/04/10 15:50:00 UTC
[jira] [Work started] (HIVE-29554) Refactor MTableColumnStatistics and MPartitionColumnStatistics to avoid code duplication
[ https://issues.apache.org/jira/browse/HIVE-29554?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Work on HIVE-29554 started by Thomas Rebele.
--------------------------------------------
> Refactor MTableColumnStatistics and MPartitionColumnStatistics to avoid code duplication
> ----------------------------------------------------------------------------------------
>
> Key: HIVE-29554
> URL: https://issues.apache.org/jira/browse/HIVE-29554
> Project: Hive
> Issue Type: Task
> Reporter: Thomas Rebele
> Assignee: Thomas Rebele
> Priority: Major
> Labels: pull-request-available
>
> Moving the common parts to a class/interface MColumnStatistics would reduce code duplication. Some methods that use these two classes could be combined, e.g.,
> * StatObjectConverter#getTableColumnStatisticsObj
> * StatObjectConverter#getPartitionColumnStatisticsObj
> and
> * StatObjectConverter#convertToMTableColumnStatistics
> * StatObjectConverter#convertToMPartitionColumnStatistics
--
This message was sent by Atlassian Jira
(v8.20.10#820010)