You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Sergey Shelukhin (JIRA)" <ji...@apache.org> on 2013/02/05 21:01:12 UTC

[jira] [Updated] (HBASE-7773) rename StoreConfiguration, remove unnecessary method

     [ https://issues.apache.org/jira/browse/HBASE-7773?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sergey Shelukhin updated HBASE-7773:
------------------------------------

    Attachment: HBASE-7773-v0.patch

The method is unnecessary as the config on which CompactionConfiguration is based ins already CompoundConfiguration, which includes family-specific values. So there's no need to get it once again. 

The interface name is confusing as it's merely a view of runtime store settings, not another configuration object.
                
> rename StoreConfiguration, remove unnecessary method
> ----------------------------------------------------
>
>                 Key: HBASE-7773
>                 URL: https://issues.apache.org/jira/browse/HBASE-7773
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Sergey Shelukhin
>            Assignee: Sergey Shelukhin
>            Priority: Minor
>         Attachments: HBASE-7773-v0.patch
>
>
> "StoreConfiguration" interface name is confusing, and one of the methods is unnecessary.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira