You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@ofbiz.apache.org by "Arun Patidar (JIRA)" <ji...@apache.org> on 2017/09/23 04:31:00 UTC
[jira] [Updated] (OFBIZ-9696) Fix type entities to follow
convention of hasTable
[ https://issues.apache.org/jira/browse/OFBIZ-9696?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Arun Patidar updated OFBIZ-9696:
--------------------------------
Summary: Fix type entities to follow convention of hasTable (was: Extend type entities to add name of detail entity where hasTable is true)
> Fix type entities to follow convention of hasTable
> --------------------------------------------------
>
> Key: OFBIZ-9696
> URL: https://issues.apache.org/jira/browse/OFBIZ-9696
> Project: OFBiz
> Issue Type: Improvement
> Components: ALL COMPONENTS
> Affects Versions: Trunk
> Reporter: Arun Patidar
> Assignee: Arun Patidar
>
> 'hasTable' field of 'Type' entities is used to give an idea that detail entity exists or not. We generally get the name of detail entity on the basis of typeId field value.
> For example :
> ContactMechType,contactMechTypeId = "POSTAL_ADDRESS" then we go to PostalAddress for detail.
> similarly,
> ContactMechType,contactMechTypeId = "TELECOM_NUMBER" then we go to TelecomNumber for detail.
> We should follow the naming convention.
> Below are some entities that are not following the pattern. Some of them are:
> - ShipmentGatewayConfigType
> - PaymentGatewayConfigType
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)