You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hbase.apache.org by vj...@apache.org on 2020/07/14 10:24:46 UTC

[hbase] branch branch-1 updated: HBASE-24693 regioninfo#isLast() should point to EMPTY_END_ROW (readability improvement)

This is an automated email from the ASF dual-hosted git repository.

vjasani pushed a commit to branch branch-1
in repository https://gitbox.apache.org/repos/asf/hbase.git


The following commit(s) were added to refs/heads/branch-1 by this push:
     new 0841f12  HBASE-24693 regioninfo#isLast() should point to EMPTY_END_ROW (readability improvement)
0841f12 is described below

commit 0841f12e4e130a556f78e1d24bffcb93de8da332
Author: Bo Cui <cu...@163.com>
AuthorDate: Tue Jul 14 15:38:23 2020 +0530

    HBASE-24693 regioninfo#isLast() should point to EMPTY_END_ROW (readability improvement)
    
    Closes #2051
    
    Signed-off-by: Duo Zhang <zh...@apache.org>
    Signed-off-by: Viraj Jasani <vj...@apache.org>
---
 hbase-common/src/main/java/org/apache/hadoop/hbase/HConstants.java | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/hbase-common/src/main/java/org/apache/hadoop/hbase/HConstants.java b/hbase-common/src/main/java/org/apache/hadoop/hbase/HConstants.java
index 9c5dd1d..94d977b 100644
--- a/hbase-common/src/main/java/org/apache/hadoop/hbase/HConstants.java
+++ b/hbase-common/src/main/java/org/apache/hadoop/hbase/HConstants.java
@@ -544,7 +544,7 @@ public final class HConstants {
   /**
    * Last row in a table.
    */
-  public static final byte [] EMPTY_END_ROW = EMPTY_START_ROW;
+  public static final byte [] EMPTY_END_ROW = EMPTY_BYTE_ARRAY;
 
   /**
     * Used by scanners and others when they're trying to detect the end of a