You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@daffodil.apache.org by "Steve Lawrence (Jira)" <ji...@apache.org> on 2021/02/04 20:59:00 UTC
[jira] [Updated] (DAFFODIL-2131) isFixedLength and related methods
in ElementBase need cleanup
[ https://issues.apache.org/jira/browse/DAFFODIL-2131?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Steve Lawrence updated DAFFODIL-2131:
-------------------------------------
Priority: Minor (was: Major)
> isFixedLength and related methods in ElementBase need cleanup
> -------------------------------------------------------------
>
> Key: DAFFODIL-2131
> URL: https://issues.apache.org/jira/browse/DAFFODIL-2131
> Project: Daffodil
> Issue Type: Improvement
> Components: Clean Ups, Front End
> Affects Versions: 2.3.0
> Reporter: Mike Beckerle
> Priority: Minor
>
> There are numerious FIXME comments in ElementBase about the inadequacies of the isFixedLength method and related methods.
> These methods do not clearly separate whether they are computing length in lengthUnits, vs. lengthInBits.
> Because of variable-width charset encodings, and because the dfdl:encoding property can be computed at run time, textual things can have fixed length measured in lengthUnits of characters, but actually have variable length at runtime in terms of the actual number of bits in the data stream.
> These two concepts should be distinguished by using naming suffixes "InLengthUnits" and "InBits".
> All these need to be rewritten in terms of optionLengthInBits or optionLengthInLengthUnits which will eliminate code duplication between the boolean-valued isFixedLength... style predicates and the methods which provide the length value.
>
--
This message was sent by Atlassian Jira
(v8.3.4#803005)