You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@harmony.apache.org by Tony Wu <wu...@gmail.com> on 2007/03/06 08:16:35 UTC
[classlib][nio_char]Suggest to rename the ConcreteCharsetTest.java
Hi all,
the ConcreteCharsetTest is an abstract class which extends
junit.framework.TestCase. It was inherited by several test classes in
the same package. This class itself can not be run as a junt testcase,
but we include all the classes as TestCase which ends with *Test* in
our build script. I think that's why it is in the exclude list. so, it
is reasonable to rename it to AbstractCharsetTestCase or whatever
rather than put it in the exclude list.
if no one objects, I'll provide a patch for this refactor.
--
Tony Wu
China Software Development Lab, IBM
Re: [classlib][nio_char]Suggest to rename the ConcreteCharsetTest.java
Posted by Alexei Zakharov <al...@gmail.com>.
+1 from me.
Regards,
2007/3/6, Richard Liang <ri...@gmail.com>:
> On 3/6/07, Tony Wu <wu...@gmail.com> wrote:
> > Hi all,
> >
> > the ConcreteCharsetTest is an abstract class which extends
> > junit.framework.TestCase. It was inherited by several test classes in
> > the same package. This class itself can not be run as a junt testcase,
> > but we include all the classes as TestCase which ends with *Test* in
> > our build script. I think that's why it is in the exclude list. so, it
> > is reasonable to rename it to AbstractCharsetTestCase or whatever
> > rather than put it in the exclude list.
> >
> > if no one objects, I'll provide a patch for this refactor.
>
> Please go ahead.
--
Alexei Zakharov,
Intel ESSD
Re: [classlib][nio_char]Suggest to rename the ConcreteCharsetTest.java
Posted by Richard Liang <ri...@gmail.com>.
On 3/6/07, Tony Wu <wu...@gmail.com> wrote:
> Hi all,
>
> the ConcreteCharsetTest is an abstract class which extends
> junit.framework.TestCase. It was inherited by several test classes in
> the same package. This class itself can not be run as a junt testcase,
> but we include all the classes as TestCase which ends with *Test* in
> our build script. I think that's why it is in the exclude list. so, it
> is reasonable to rename it to AbstractCharsetTestCase or whatever
> rather than put it in the exclude list.
>
> if no one objects, I'll provide a patch for this refactor.
Please go ahead.
>
> --
> Tony Wu
> China Software Development Lab, IBM
>
--
Richard Liang
China Development Lab, IBM