You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Zhihong Yu (Commented) (JIRA)" <ji...@apache.org> on 2012/03/04 16:11:59 UTC

[jira] [Commented] (HBASE-5514) Compile against hadoop 0.24-SNAPSHOT

    [ https://issues.apache.org/jira/browse/HBASE-5514?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13221912#comment-13221912 ] 

Zhihong Yu commented on HBASE-5514:
-----------------------------------

Similar reflection code is introduced for both tests.
Can we extract the new code into a helper class or method in org.apache.hadoop.hbase.regionserver.wal package ?

{code}
+    if (syncMethod != null) {
+      syncMethod.invoke(out, new Object[]{});
+    }
{code}
Is the above check needed ? If getMethod() calls fail, there should be exception thrown that would fail the test.
                
> Compile against hadoop 0.24-SNAPSHOT
> ------------------------------------
>
>                 Key: HBASE-5514
>                 URL: https://issues.apache.org/jira/browse/HBASE-5514
>             Project: HBase
>          Issue Type: Bug
>          Components: build, test
>    Affects Versions: 0.92.0, 0.94.0
>            Reporter: Mingjie Lai
>            Assignee: Mingjie Lai
>            Priority: Minor
>             Fix For: 0.94.0
>
>         Attachments: HBASE-5514-2.patch, HBASE-5514-3.patch, HBASE-5514.patch
>
>
> Need to compile hbase against the latest hadoop trunk which just had NN HA merged in. 
> 1) add a hadoop 0.24 profile
> 2) HBASE-5480
> 3) HADOOP-8124 removed deprecated Syncable.sync(). It brings compile errors for hbase against hadoop trunk(0.24). TestHLogSplit and TestHLog still call the deprecated sync(). Need to replace it with hflush() so the compilation can pass. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira