You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "David Bowen (JIRA)" <ji...@apache.org> on 2007/01/29 21:02:49 UTC

[jira] Updated: (HADOOP-948) Coding style issues

     [ https://issues.apache.org/jira/browse/HADOOP-948?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

David Bowen updated HADOOP-948:
-------------------------------

    Attachment: hadoop-948.patch

> Coding style issues 
> --------------------
>
>                 Key: HADOOP-948
>                 URL: https://issues.apache.org/jira/browse/HADOOP-948
>             Project: Hadoop
>          Issue Type: Bug
>          Components: metrics
>            Reporter: David Bowen
>            Priority: Minor
>         Attachments: hadoop-948.patch
>
>
> I would like to recommend some mainly stylistic changes in the recent fix of http://issues.apache.org/jira/browse/HADOOP-886.  The file in question is CodeFactory.java, and the reasons for the changes are:
>    * It is generally preferable to avoid multiple return statements.
>    * It is nearly always preferable to use curly braces and a newline after an if (condition).
>    * There's no benefit to doing the hash lookup twice in the common case (by calling contains and then get).
> (1) and (2) are commonly found in Java coding style guidelines as they make the code more readable. 
> I'll attach the fix shortly.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.