You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Arun C Murthy (JIRA)" <ji...@apache.org> on 2012/10/11 19:45:41 UTC

[jira] [Closed] (HADOOP-8700) Move the checksum type constants to an enum

     [ https://issues.apache.org/jira/browse/HADOOP-8700?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Arun C Murthy closed HADOOP-8700.
---------------------------------

    
> Move the checksum type constants to an enum
> -------------------------------------------
>
>                 Key: HADOOP-8700
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8700
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: util
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>            Priority: Minor
>             Fix For: 0.23.3, 2.0.2-alpha
>
>         Attachments: c8700_20120815b.patch, c8700_20120815.patch, hadoop-8700-branch-0.23.patch.txt
>
>
> In DataChecksum, there are constants for crc types, crc names and crc sizes.  We should move them to an enum for better coding style.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira