You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Till Rohrmann (JIRA)" <ji...@apache.org> on 2016/08/25 14:28:22 UTC

[jira] [Commented] (FLINK-4343) Implement new TaskManager

    [ https://issues.apache.org/jira/browse/FLINK-4343?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15436982#comment-15436982 ] 

Till Rohrmann commented on FLINK-4343:
--------------------------------------

I've tried to outline the interaction of the new {{TaskManager}} with the {{ResourceManager}} and the {{JobManager}}. I've attached the document as a link to this issue. The main addition compared to the existing {{TaskManager}} would be the introduction of a {{SlotManager}} which manages the slot-JobManager assignment.

> Implement new TaskManager
> -------------------------
>
>                 Key: FLINK-4343
>                 URL: https://issues.apache.org/jira/browse/FLINK-4343
>             Project: Flink
>          Issue Type: New Feature
>          Components: Cluster Management
>            Reporter: Stephan Ewen
>
> This is the parent issue for the efforts to implement the {{TaskManager}} changes based on FLIP-6 (https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=65147077)
> Because of the breadth of changes, we should implement a new version of the {{TaskManager}} (let's call it {{TaskExecutor}}) rather than updating the current {{TaskManager}}. That will allow us to keep a working master branch.
> At the point when the new cluster management is on par with the current implementation, we will drop the old {{TaskManager}} and rename the {{TaskExecutor}} to {{TaskManager}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)