You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ant.apache.org by Kev Jackson <ke...@it.fts-vn.com> on 2004/12/03 12:05:57 UTC

[Patch] style changes to taskdefs/Rmic

Just some small changes that reduce the whining my IDE does :)

What is the policy w.r.t TLA's in method names?

e.g. getIiopOpts versus getIIOPOpts ?

or setIDLOpts versus setIdlOpts ?

I think the all CAPS accronym is easier to read, but I'm not sure if it 
breaks the style

Kev



Re: [Patch] style changes to taskdefs/Rmic

Posted by Kev Jackson <ke...@it.fts-vn.com>.
>If the method is public or protected and the class has been part of
>Ant 1.6.2 and the method has been present, don't change its name ;-)
>
>  
>
I've got to get this "using ant programmatically" thing sorted - I'm so 
used to using Ant as a build tool that when I make a change, so long as 
it doesn't affect any other classes I'm happy, I keep forgetting the 
people who write code against Ant as an API. Sorry

Kev

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Re: [Patch] style changes to taskdefs/Rmic

Posted by Stefan Bodewig <bo...@apache.org>.
On Fri, 03 Dec 2004, Kev Jackson <ke...@it.fts-vn.com> wrote:

> What is the policy w.r.t TLA's in method names?

If the method is public or protected and the class has been part of
Ant 1.6.2 and the method has been present, don't change its name ;-)

> e.g. getIiopOpts versus getIIOPOpts ?
> 
> or setIDLOpts versus setIdlOpts ?
> 
> I think the all CAPS accronym is easier to read,

I agree.

> but I'm not sure if it breaks the style

More likely backwards compatibility.

Cheers

        Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Re: [Patch] style changes to taskdefs/Rmic

Posted by Kev Jackson <ke...@it.fts-vn.com>.
Peter Reilly wrote:

> Kev Jackson wrote:
>
>> Just some small changes that reduce the whining my IDE does :)
>>
>>
> Checkstyle whines about missing description for paramters.

Sorry about that, here's an update that hopefully fixes those.

Re: [Patch] style changes to taskdefs/Rmic

Posted by Peter Reilly <pe...@apache.org>.
Kev Jackson wrote:

> Just some small changes that reduce the whining my IDE does :)
>
>
Checkstyle whines about missing description for paramters.

>     /**
>      * Specify the JDK version for the generated stub code.
>      * Specify &quot;1.1&quot; to pass the &quot;-v1.1&quot; option to rmic.</td>
>+     * @param stubVersion
>      */
>  
>
Peter

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org