You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hudi.apache.org by "sivabalan narayanan (Jira)" <ji...@apache.org> on 2021/01/31 13:35:00 UTC
[jira] [Commented] (HUDI-1315) introduce a builder pattern init the
table properties
[ https://issues.apache.org/jira/browse/HUDI-1315?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17275873#comment-17275873 ]
sivabalan narayanan commented on HUDI-1315:
-------------------------------------------
[~309637554]: May I know if you are working on this. If not, can I take it up. I see some diffs adding more constructors. We need to get this in sooner rather than later.
> introduce a builder pattern init the table properties
> -----------------------------------------------------
>
> Key: HUDI-1315
> URL: https://issues.apache.org/jira/browse/HUDI-1315
> Project: Apache Hudi
> Issue Type: Improvement
> Components: Common Core
> Reporter: liwei
> Assignee: liwei
> Priority: Major
>
> introduce a builder pattern init the table properties. those overloaded {{initXX}} are hard to read.
> such as
> /**
> * Used primarily by tests, examples.
> */
> public static HoodieTableMetaClient initTableType(Configuration hadoopConf, String basePath, HoodieTableType tableType,
> String tableName, String payloadClassName, String indexType) throws IOException {
> return initTableType(hadoopConf, basePath, tableType, tableName, null, payloadClassName,
> null, null, null, null, indexType);
> }
--
This message was sent by Atlassian Jira
(v8.3.4#803005)