You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Greg Stein <gs...@gmail.com> on 2008/10/21 15:29:05 UTC

Re: svn commit: r33816 - trunk/subversion/libsvn_fs_fs

On Tue, Oct 21, 2008 at 7:53 AM,  <hw...@tigris.org> wrote:
>...
> +++ trunk/subversion/libsvn_fs_fs/rep-cache.c   Tue Oct 21 07:53:45 2008        (r33816)
> @@ -28,18 +28,16 @@
>  /* A few magic values */
>  #define REP_CACHE_SCHEMA_FORMAT   1
>
> -const char *upgrade_sql[] = { NULL,
> +static const char *upgrade_sql[] = { NULL,

oh. looks like an extra "const" ought to be in there, too. Right after the *

Right now, it is classified as a non-const global.

>...
> +  "create table rep_cache (hash text not null primary key,   "

not null is implied, but is (obviously) fine to leave in :-)

>...

The caching of prepared statements looks good. I bet we can get some
really clean stuff in just a couple more iterations, based on working
more with the API.

Cheers,
-g

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: r33816 - trunk/subversion/libsvn_fs_fs

Posted by "Hyrum K. Wright" <hy...@mail.utexas.edu>.
Greg Stein wrote:
> On Tue, Oct 21, 2008 at 7:53 AM,  <hw...@tigris.org> wrote:
>> ...
>> +++ trunk/subversion/libsvn_fs_fs/rep-cache.c   Tue Oct 21 07:53:45 2008        (r33816)
>> @@ -28,18 +28,16 @@
>>  /* A few magic values */
>>  #define REP_CACHE_SCHEMA_FORMAT   1
>>
>> -const char *upgrade_sql[] = { NULL,
>> +static const char *upgrade_sql[] = { NULL,
> 
> oh. looks like an extra "const" ought to be in there, too. Right after the *
> 
> Right now, it is classified as a non-const global.

Sounds good, r33818.

>> ...
>> +  "create table rep_cache (hash text not null primary key,   "
> 
> not null is implied, but is (obviously) fine to leave in :-)
> 
>> ...
> 
> The caching of prepared statements looks good. I bet we can get some
> really clean stuff in just a couple more iterations, based on working
> more with the API.

Agreed.

-Hyrum